Bug 52450 - RFE: Connectix virtualpc support [anaconda ignores glibc install falure, pretends everything's fine]
RFE: Connectix virtualpc support [anaconda ignores glibc install falure, pret...
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 16:11 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 11:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-23 16:11:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.1b1; Mac_PowerPC)

Description of problem:
If the install of the i686 glibc (or other vital packages) fails for some 
reason anaconda ignores the problem and proceeds with the install, 
giving no feedback to the user that it is encountering problems.

In my particular case, I am trying to install RedHat 7.x on Connectix's 
Virtual PC 4.x.  Their appears to be a problem related to the 
Connectix i686 emulation, since the i383 glibc seems to run, but the 
i686 optimized one runs into serious problems, with ldconfig 
segfaulting (very bad!).  However, it is far from obvious to a naive user 
that this is indeed the problem.  Usenet newsgroups and Connectix 
support forums show people complaining that the RedHat installer 
couldn't write their boot sector -- this being the first indication of the 
problem (the dev package fails to install, so /dev/hda doesn't exist in 
the new filesystem).

Although the "install.log" file reveals the extent of the problem (huge 
numbers packages which didn't install because their (or their 
dependencies) %pre scripts couldn't run, and huge numbers of 
packages whose %post or %trigger scripts didn't run), there is no 
indication that these package installs are failing.

Perhaps some of the blame lies with rpm, rather than anaconda, but 
it certainly is not okay for users to be told that the install has 
completed successfully when the log shows numerous errors.  (Of 
course, some of the blame must also surely rest with Connectix 
whose buggy emulation appears to be the root cause of the problem 
-- of course, they may say that since Windows runs fine, they don't 
care).

Sadly, even once I had diagnosed the problem, there seemed to be 
no way for me to tell the installer that it should ignore the fact that the 
processor appears to be an i686 and that it should actually install the 
more generic i386 packages.  (If there is a way to do this, let me 
know and I'll give the installer another shot).

It would be cool if we could get this problem fixed for 7.2.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Virtual PC 4.x (either on Mac OS 9, Mac OS X)
2. Attempt to install RH 7.x
3. Watch for first report of errors and compare to /tmp/install.log
	

Actual Results:  Mondo badness, unbootable install.

Expected Results:  Happiness and joy.

Additional info:
Comment 1 Matt Wilson 2001-08-23 17:00:31 EDT
Connectix needs to fix their emulation or not report that they can handle
instructions that they can't really handle.

Note You need to log in before you can comment on or make changes to this bug.