Bug 524507 - Trying to open a flac file with libsndfile 1.0.20 x86_64 on rawhide fails
Summary: Trying to open a flac file with libsndfile 1.0.20 x86_64 on rawhide fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsndfile
Version: 12
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-20 22:49 UTC by stan
Modified: 2009-12-03 05:07 UTC (History)
3 users (show)

Fixed In Version: 1.0.20-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-03 05:07:30 UTC


Attachments (Terms of Use)

Description stan 2009-09-20 22:49:23 UTC
Description of problem:
When using libsndfile to open a flac file on rawhide, the error message 
'This version of libsndfile was not compiled with flac support' comes up.
And it is not possible to open the file.

Version-Release number of selected component (if applicable):
libsndfile-1.0.20-2.fc12.x86_64


How reproducible: Every time


Steps to Reproduce:
1. Call sf_open in the libsndfile api with a flac file as target.
2.
3.
  
Actual results:  The above error message.


Expected results:  File opens.


Additional info:  As far as I recall, this works on F10 and F11.

Comment 1 stan 2009-09-21 03:35:40 UTC
libsndfile doesn't work with ogg files either, so you probably need to install ogg-vorbis (libogg and libvorbisenc and libvorbisfile?) before you compile the package too.

If I compile the 1.0.20 tarball from source with FLAC and ogg-vorbis installed, both work when called from the api.

Comment 2 Orcan Ogetbil 2009-11-03 17:51:55 UTC
I requested comaintainership for this package on F-10,F-11,F-12,devel to fix this bug, as well as other bugs filed against libsndfile. 

Andreas, could you grant me permission, since this package is very important for many audio people?

Comment 3 Fedora Update System 2009-11-14 10:50:00 UTC
libsndfile-1.0.20-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libsndfile-1.0.20-3.fc12

Comment 4 Fedora Update System 2009-11-16 07:34:36 UTC
libsndfile-1.0.20-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libsndfile'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11592

Comment 5 Bug Zapper 2009-11-16 12:41:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 stan 2009-11-17 18:35:35 UTC
The new version showed up in today's updates on my F12 system.  I tested both ogg and flac, and both worked when linking with the new version of libsndfile.

Thank you.

Comment 7 Fedora Update System 2009-12-03 05:07:25 UTC
libsndfile-1.0.20-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.