Bug 524586 - Initscript for ipsec daemon is not LSB compliant
Summary: Initscript for ipsec daemon is not LSB compliant
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openswan
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Avesh Agarwal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject
TreeView+ depends on / blocked
 
Reported: 2009-09-21 11:12 UTC by Aleš Mareček
Modified: 2010-09-22 15:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-19 17:21:14 UTC


Attachments (Terms of Use)
Patch to fix the issue (2.48 KB, patch)
2009-09-22 19:01 UTC, Avesh Agarwal
no flags Details | Diff
Patch to fix the issue (1.32 KB, patch)
2009-09-22 19:03 UTC, Avesh Agarwal
no flags Details | Diff
A new init script (4.79 KB, patch)
2009-09-23 05:02 UTC, Avesh Agarwal
no flags Details | Diff
An updated init script (4.53 KB, text/plain)
2009-10-06 15:59 UTC, Avesh Agarwal
no flags Details

Description Aleš Mareček 2009-09-21 11:12:25 UTC
Description of problem:
Acording to https://fedoraproject.org/wiki/Packaging/SysVInitScript isn't initscript for ipsec compliant.
Usage writes help values with "--" and for ipsec usage instead of ipsec initscript usage.

Version-Release number of selected component (if applicable):
openswan-2.6.22-2.fc12

How reproducible:
always

Steps to Reproduce:
1. $ service ipsec whatever
  
Actual results:
[root@localhost ~]# service ipsec rwgwreg
Usage: ipsec setup [ --showonly ] {--start|--stop|--restart}
       ipsec setup --status

Expected results:
Usage: ipsec {start|stop|restart|condrestart|reload|force-reload|status}

Additional info:

Comment 1 Avesh Agarwal 2009-09-22 19:01:32 UTC
Created attachment 362130 [details]
Patch to fix the issue

I have attached a patch for this, and will now be discussing with upstream. I would appreciate if you can also provide your feedback.

Comment 2 Avesh Agarwal 2009-09-22 19:03:29 UTC
Created attachment 362131 [details]
Patch to fix the issue

Previous patch was wrong, this is the correct patch.

Comment 3 Avesh Agarwal 2009-09-23 05:02:01 UTC
Created attachment 362166 [details]
A new init script

I am attaching a new ipsec init script here. Any feedback is appreciated.

Comment 4 Avesh Agarwal 2009-10-06 15:59:47 UTC
Created attachment 363845 [details]
An updated init script

It is a new init script for Openswan. It addresses 524586 (this bz), and 524589.
It is an attempt to make a better init script for Openswan. Any feedback is appreciated.

Comment 5 Bug Zapper 2009-11-16 12:42:31 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Avesh Agarwal 2010-04-19 17:21:14 UTC
This has been tested in the latest Openswan release in F12, and the issue does
not appear. I am going to close it now and if the issue is encountered again,
please reopen the bug. Thanks for reporting the issue.


Note You need to log in before you can comment on or make changes to this bug.