Bug 524596 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd (deleted) "write" access on /home/ggw.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd (deleted) "write" acces...
Keywords:
Status: CLOSED DUPLICATE of bug 522878
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:aff8452dfed...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 12:39 UTC by G.Wolfe Woodbury
Modified: 2009-10-20 22:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-20 22:35:55 UTC


Attachments (Terms of Use)

Description G.Wolfe Woodbury 2009-09-21 12:39:39 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd (deleted) "write" access on /home/ggw.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/ggw [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd (deleted)
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-6.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-33.fc12.i686.PAE #1 SMP
                              Thu Sep 17 15:40:35 EDT 2009 i686 i686
Alert Count                   3
First Seen                    Mon 21 Sep 2009 08:37:11 AM EDT
Last Seen                     Mon 21 Sep 2009 08:37:11 AM EDT
Local ID                      d98fde7c-0a31-4368-9da3-26bf0f69dce5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253536631.701:83): avc:  denied  { write } for  pid=1273 comm="abrtd" name="ggw" dev=sda7 ino=802817 scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1253536631.701:83): avc:  denied  { add_name } for  pid=1273 comm="abrtd" name=".abrt" scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1253536631.701:83): avc:  denied  { create } for  pid=1273 comm="abrtd" name=".abrt" scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1253536631.701:83): arch=40000003 syscall=39 success=yes exit=0 a0=8b357ac a1=1c0 a2=bfc8d434 a3=8b2fc94 items=0 ppid=1 pid=1273 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe=2F7573722F7362696E2F6162727464202864656C6574656429 subj=system_u:system_r:abrt_t:s0 key=(null)


audit2allow suggests:

#============= abrt_t ==============
allow abrt_t user_home_dir_t:dir { write create add_name };

Comment 1 Daniel Walsh 2009-10-20 22:35:55 UTC

*** This bug has been marked as a duplicate of bug 522878 ***


Note You need to log in before you can comment on or make changes to this bug.