Bug 524598 - Systems running builds from livecd-tools fail if left running for long time
Summary: Systems running builds from livecd-tools fail if left running for long time
Keywords:
Status: CLOSED DUPLICATE of bug 465725
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 12:48 UTC by John Florian
Modified: 2009-10-07 01:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-07 01:53:09 UTC


Attachments (Terms of Use)

Description John Florian 2009-09-21 12:48:40 UTC
Description of problem:
The use of LVM snapshots (COW) to provide a writable file system is clever, but has a downside that prevents systems from running those images for long periods of time without a necessary reboot.  Eventually the snapshot will exhaust all available resources despite the normal logrotate, etc. because the COW tends not to reuse blocks much, if at all. 

Version-Release number of selected component (if applicable):
livecd-tools-020.1-1.fc10.i386
lvm2-2.02.39-7.fc10.i386

How reproducible:
Very easy.

Steps to Reproduce:
1. Boot a system running a image created by livecd-tools.
2. Let run a long time (depends on available RAM) or accelerate the process by frequently writing to the syslog for example.  The same basic problem can be seen with "dd if=/dev/zero of=/tmp/foo bs=1M count=NNN" where NNN is the number of MB free minus a few.  Erase the file and notice that df shows no reclamation of the space.  Overwriting the file leads to the same results.
  
Actual results:
Once RAM is exhausted the system becomes quite broken with most commands returning: seg. fault, i/o error, or command not found.

Expected results:
The file system should just become full and be no worse than a standard hard disk installation that has become full.

Additional info:
The livecd-tools package is very enticing for creating embedded systems around PC/104 hardware, but this issue makes it infeasible as it currently exists.  I will be reworking our systems to boot with /tmp and /var mounted over tmpfs, which does achieve the expected results (provided all other parts are read-only).  It would be really nice if livecd-tools did this by default.

Comment 1 Jeremy Katz 2009-10-07 01:53:09 UTC

*** This bug has been marked as a duplicate of bug 465725 ***


Note You need to log in before you can comment on or make changes to this bug.