Bug 524612 - snapshot rollback destroys registered system
Summary: snapshot rollback destroys registered system
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.8
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On: 624651
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 13:44 UTC by Jiri Kastner
Modified: 2010-10-15 17:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-15 17:59:06 UTC


Attachments (Terms of Use)
gziped up2date log (3.05 KB, application/x-gzip)
2009-09-21 13:44 UTC, Jiri Kastner
no flags Details

Description Jiri Kastner 2009-09-21 13:44:35 UTC
Created attachment 361939 [details]
gziped up2date log

Description of problem:
satellite sends wrong data using rhn_check for rollback.
when you do sequence of up2date xxxx and snapshot rollbacks after re-registration.
e.g.:
up2date acpid bind-utils bind-libs,
rollback,
up2date libxml2,
rollback to snapshot before update of libxml2.
system has destroyed deps, because of removing only libxml2.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. register system to satellite, remove that system, register again, create initial snapshot in satellite and update package list (after creation of initial snapshot followed by updating package profile initial snapshot shows delta of packages equal to sum of all packages!).
2. up2date acpid bind-libs bind-utils, do rollback to first snapshot before update of those packages (not initial as it show all packages as list of change).
3. up2date -p
4. up2date libxml2 and do rollback to first snapshot showing libxml2 as changed package

  
Actual results:
action is in satellite as picked-up and not finished, because as dependency of libxml2 removal is removed up2date itself and rhn_check fails with error:
[Mon Sep 21 08:59:41 2009] up2date Removing packages from package profile: ['libxml2-2.6.16-12.7', 'libxml2-devel-2.6.16-12.6', 'libxml2-python-2.6.16-12.6', 'libxslt-1.1.11-1.el4_7.2', 'perl-XML-LibXML-1.58-3.el4', 'perl-XML-LibXML-Common-0.13-8.el4', 'setools-2.3-4', 'sos-1.7-9.35.el4', 'up2date-4.8.1-33.el4', 'xmlsec1-1.2.6-3', 'xmlsec1-openssl-1.2.6-3', 'yum-2.2.2-1.rhts.EL4'][Mon Sep 21 08:59:41 2009] up2date ERROR: can not find RHNS CA file:: /usr/share/rhn/RHNS-CA-CERT




Expected results:
satellite after re-registration with marked upload of package profile to server will track package transactions properly or up2date doesn't allow such transaction.

Additional info:

Comment 7 Jan Pazdziora 2010-07-26 15:28:07 UTC
Taking.

Comment 8 Jan Pazdziora 2010-07-26 15:29:25 UTC
Hello,

I'll need exact version of up2date confirmed where this issue happened.

Also, can you please confirm whether this is or isn't a regression against RHEL 4.6?

Thank you,

Jan

Comment 9 Jan Hutař 2010-07-27 10:34:37 UTC
Hello,
from initial comment it looks like this was with up2date-4.8.1-33.el4. I'll confirm and will report results here.

Regards,
Jan


Note You need to log in before you can comment on or make changes to this bug.