Bug 524644 - schedd unresponsive during cleanup of job spool directories
Summary: schedd unresponsive during cleanup of job spool directories
Keywords:
Status: CLOSED DUPLICATE of bug 523806
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid
Version: 1.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: 1.2
: ---
Assignee: grid-maint-list
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 15:38 UTC by Jon Thomas
Modified: 2009-09-23 03:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-23 03:06:17 UTC


Attachments (Terms of Use)

Description Jon Thomas 2009-09-21 15:38:00 UTC
When jobs vacate the pool, the condor_schedd can take a lot of time in cleaning up job spool directories. During this period, the schedd is unresponsive.

Customer noted that breaking up the cleanup tasks into smaller chunks would help make the schedd more responsive.

Comment 1 Jon Thomas 2009-09-21 15:39:52 UTC
This is related to

https://bugzilla.redhat.com/show_bug.cgi?id=523801

Avoiding job spool creation might fix sufficiently fix this problem.

Comment 2 Matthew Farrellee 2009-09-23 03:06:17 UTC

*** This bug has been marked as a duplicate of bug 523806 ***


Note You need to log in before you can comment on or make changes to this bug.