Bug 524695 - qemu should print strerror info for disk/kernel/initrd access errors
qemu should print strerror info for disk/kernel/initrd access errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtBlocker
  Show dependency treegraph
 
Reported: 2009-09-21 14:33 EDT by Cole Robinson
Modified: 2009-10-02 11:18 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-02 11:18:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2009-09-21 14:33:10 EDT
Example:

# virsh start f11_1
error: Failed to start domain f11_1
error: internal error unable to start guest: qemu: could not open disk image
/root/f11_1

Since these messages are often the only error indication to users, it would help to make them as descriptive as possible. This is especially important for F12:

Disk access example: bz 517379
Kernel/Initrd ex   : bz 523960
Comment 1 Justin M. Forbes 2009-10-01 12:16:17 EDT
Patch sent upstream:

http://lists.gnu.org/archive/html/qemu-devel/2009-10/txtSH68ZJDZCh.txt
Comment 2 Justin M. Forbes 2009-10-02 11:18:41 EDT
This issue is resolved with qemu-0.11.0-3.fc12

Note You need to log in before you can comment on or make changes to this bug.