Bug 524706 - Citrix client / receiver do not play sound in a windows session from a Fedora 11 or Fedora 12 client
Summary: Citrix client / receiver do not play sound in a windows session from a Fedor...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 19:50 UTC by Dave Jones
Modified: 2009-11-17 20:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-17 17:48:12 UTC


Attachments (Terms of Use)

Description Dave Jones 2009-09-21 19:50:14 UTC
Description of problem:
Citrix client (or receiver) do not have sound in a windows session from a Fedora 11 or Rawhide (12) client.  No sound device is created in windows device manager and media player will not play wav files.

Version-Release number of selected component (if applicable):
Tested Fedora 11 & Rawhide (12)

How reproducible:
Always

Steps to Reproduce:
1. Install openmotif & citrix client or receiver, create necessary symlinks, etc
2. connect to a windows citrix session
3. try to play a wav file (or anything else?) in win media player
  
Actual results:
"windows media player cannot play the file because there is a problem with your sound device..."

Expected results:
Hear the wav file playing

Additional info:
I seem to remember this working in Fedora 10, and I know it works in Centos 5.3

Comment 1 Dave Jones 2009-09-25 20:26:16 UTC
Has anyone else experienced this?
I have tested and seen the same issue with the Scientific Linux 5.3 Live CD.
However I have confirmed that it does work on an installed-from-DVD copy of Centos 5.3.

Thanks

Comment 2 Lennart Poettering 2009-09-29 04:00:20 UTC
Uh, does this software still rely on the obsolete OSS /dev/dsp interfaces? If so, it needs to be fixed, since we don't support OSS anymore on rawhide. OSS has been obsolete for 10 years now or so. If apps still use that then uh, some people need to come out of the rock they have been living under.

You still can reenable /dev/dsp by some hackery in /etc/modprobe.d/dist-oss.conf.

Comment 3 Lennart Poettering 2009-09-29 04:01:05 UTC
Small correction in fact OSS was already dropped in F11, not only rawhide.

Comment 4 Dave Jones 2009-09-30 18:53:34 UTC
Hello sir.

I have tested your solution and it works.
I will take this up with our Citrix rep.

Thank you,
Dave

Comment 5 Lennart Poettering 2009-10-02 09:13:08 UTC
Closing then.

Comment 6 Dave Jones 2009-11-16 19:28:34 UTC
The work-around of un-commenting in /etc/modprobe.d/dist-oss.conf does not seem to work in Fedora 12, which should be released tomorrow.

Does anyone have a similar fix for F12?  So far it appears that the Citrix devs have no intention of fixing this.

Thanks,
Dave

Comment 7 Dave Jones 2009-11-17 17:47:53 UTC
Well, today the un-comment fix seems to work.
There were a few updates last night.  Maybe one of them fixed it?

For those of you looking for the solution in Fedora 11 or 12, you need something like this:

$ cat /etc/modprobe.d/dist-oss.conf
# OSS Sound Support
# This has been disabled in F11 onwards because it can interfere with the
# PulseAudio sound service (a legacy OSS application can prevent PulseAudio
# applications from playing sound by preventing PulseAudio from (re-)opening
# the sound device). To re-enable support, uncomment the following line:
#
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss


Which means you probably need to un-comment the "install snd-pcm /sbin/modprobe" line in your file.

The risk is that this is unsupported and may do wonky things to your sound or adversely affect system stability.

Thanks,
Dave


Note You need to log in before you can comment on or make changes to this bug.