Bug 52471 - when try to 'startx', complain about "could not open default font 'fixed'". xfs problem??
when try to 'startx', complain about "could not open default font 'fixed'". x...
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86-Servers (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-23 21:51 EDT by shengchao li
Modified: 2007-04-18 12:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-07 08:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shengchao li 2001-08-23 21:51:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; AIRF)

Description of problem:
can not start X windows system. complaint about "could not open default 
font 'fixed'". checked the fonts directories and see no problem there.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ftp install
2.install "X windows system", "KDE","sound and multimedia 
support","network support","EMacs","utilities"
3.after done, reboot
	

Actual Results:  graphics mode does not show up. even run 'startx' in root 
can not
bring up X windows.

Expected Results:  expect to start graphics login for KDE

Additional info:

ftp installed to a pentium 133 PC using ext3 file system. when 
install,chosed 'custom', installed 'X window system", "KDE", "sound and 
multimedia support", "Network support", "Emacs", "Utilities".
after rebooting, failed to start X. if run 'startx' in root, produce this 
screen output and failed to startx:

XFree86 Version 3.3.6a / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: April 19, 2001
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.4.7-0.13.1smp i686 [ELF] 
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 1):
      s3_savage, NV1, STG2000, RIVA 128, RIVA TNT, RIVA TNT2,
      RIVA ULTRA TNT2, RIVA VANTA, RIVA ULTRA VANTA, RIVA INTEGRATED,
      GeForce 256, GeForce DDR, Quadro, GeForce2 GTS, GeForce2 GTS (rev1),
      GeForce2 Ultra, Quadro 2 Pro, GeForce2 MX, GeForce2 MX DDR,
      Quadro 2 MXR, ET4000, ET4000W32, ET4000W32i, ET4000W32i_rev_b,
      ET4000W32i_rev_c, ET4000W32p, ET4000W32p_rev_a, ET4000W32p_rev_b,
      ET4000W32p_rev_c, ET4000W32p_rev_d, ET6000, ET6100, et3000, pvga1,
      wd90c00, wd90c10, wd90c30, wd90c24, wd90c31, wd90c33, gvga, r128, 
ati,
      sis86c201, sis86c202, sis86c205, sis86c215, sis86c225, sis5597,
      sis5598, sis6326, sis530, sis620, sis300, sis630, sis540, tvga8200lx,
      tvga8800cs, tvga8900b, tvga8900c, tvga8900cl, tvga8900d, tvga9000,
      tvga9000i, tvga9100b, tvga9200cxr, tgui9400cxi, tgui9420, 
tgui9420dgi,
      tgui9430dgi, tgui9440agi, cyber9320, tgui9660, tgui9680, tgui9682,
      tgui9685, cyber9382, cyber9385, cyber9388, cyber9397, cyber9520,
      cyber9525, 3dimage975, 3dimage985, cyber9397dvd, blade3d, cyberblade,
      clgd5420, clgd5422, clgd5424, clgd5426, clgd5428, clgd5429, clgd5430,
      clgd5434, clgd5436, clgd5446, clgd5480, clgd5462, clgd5464, clgd5465,
      clgd6205, clgd6215, clgd6225, clgd6235, clgd7541, clgd7542, clgd7543,
      clgd7548, clgd7555, clgd7556, ncr77c22, ncr77c22e, cpq_avga, 
mga2064w,
      mga1064sg, mga2164w, mga2164w AGP, mgag200, mgag100, mgag400, oti067,
      oti077, oti087, oti037c, al2101, ali2228, ali2301, ali2302, ali2308,
      ali2401, cl6410, cl6412, cl6420, cl6440, video7, ark1000vl, 
ark1000pv,
      ark2000pv, ark2000mt, mx, realtek, s3_virge, AP6422, AT24, AT3D,
      s3_svga, NM2070, NM2090, NM2093, NM2097, NM2160, NM2200, ct65520,
      ct65525, ct65530, ct65535, ct65540, ct65545, ct65546, ct65548,
      ct65550, ct65554, ct65555, ct68554, ct69000, ct64200, ct64300,
      mediagx, V1000, V2100, V2200, p9100, spc8110, i740, i740_pci,
      Voodoo Banshee, Voodoo3, i810, i810-dc100, i810e, i815, smi, generic
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) Mouse: type: MouseSystems, device: /dev/mouse, baudrate: 1200
(**) Mouse: buttons: 5
(**) Mouse: zaxismapping: (-)4 (+)5
(**) SVGA: Graphics device ID: "S3 ViRGE (generic)"
(**) SVGA: Monitor ID: "Digital 15 in. Color (FR-PCXBV-PC)"
(--) SVGA: Mode "1024x768" needs hsync freq of 80.21 kHz. Deleted.
(--) SVGA: Mode "1024x768" needs hsync freq of 70.24 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 89.62 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 70.88 kHz. Deleted.
(--) SVGA: Mode "1152x864" needs hsync freq of 76.01 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 107.16 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 74.59 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 78.86 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 81.13 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 91.15 kHz. Deleted.
(--) SVGA: Mode "1400x1050" needs hsync freq of 77.04 kHz. Deleted.
(--) SVGA: Mode "1400x1050" needs hsync freq of 82.65 kHz. Deleted.
(--) SVGA: Mode "1400x1050" needs hsync freq of 93.88 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 75.00 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 87.50 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 93.75 kHz. Deleted.
(--) SVGA: Mode "1600x1200" needs hsync freq of 105.77 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
(**) FontPath set to "unix/:7100"
(--) SVGA: PCI: S3 ViRGE rev 6, Memory @ 0xec000000
(--) SVGA: S3V: ViRGE rev 6, Linear FB @ 0xec000000
(--) SVGA: Detected S3 ViRGE
(--) SVGA: using driver for chipset "s3_virge"
(--) SVGA: videoram:  2048k
(--) SVGA: Ramdac speed: 135 MHz  (95 MHz for 16 bpp)
(--) SVGA: Detected current MCLK value of 50.114 MHz
(--) SVGA: chipset:  s3_virge
(--) SVGA: videoram: 2048k
(**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
(--) SVGA: Maximum allowed dot-clock: 95.000 MHz
(**) SVGA: Mode "800x600": mode clock =  60.750
(--) SVGA: Virtual resolution set to 800x600
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: s3_virge: Using hardware cursor
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: 8x8 pattern fill
(--) SVGA: XAA: 8x8 color expand pattern fill
(--) SVGA: XAA: CPU to screen color expansion (bitmap, TE/NonTE imagetext, 
TE/NonTE polytext)
(--) SVGA: XAA: Using 6 128x128 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and non-transparent stipples
(--) SVGA: XAA: Horizontal and vertical lines and segments

Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send
the full server output, not just the last messages

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
Comment 1 Christopher Stone 2001-08-24 03:35:46 EDT
I get the same error.  I have found that to get X running you must do the following.

Copy all the font paths from your /etc/X11/fs/config file into your
/etc/X11/XF86Config file so that you have a FontPath entry for each font path
listed in your fs/config file.  Next, comment out the font paths
"/usr/X11R6/lib/X11/fonts/Type1" and "/usr/share/fonts/ja/TrueType" and
"unix/:7100".  After doing all this, X should start.  I tried commenting out
these paths in the fs/config file, restarting xfs but this did not help.  There
are some slight font problems with mozilla after doing this, but I think this is
because the Type1 fonts are commented out.  I am no expert on all this, but
through a lot of trial and error, this is how I got it working.
Comment 2 Christopher Stone 2001-08-24 03:48:09 EDT
One additional note:  I too am using a 3.3.6 X server and KDE
Comment 3 Mike A. Harris 2001-08-24 10:21:36 EDT

*** This bug has been marked as a duplicate of 51033 ***
Comment 4 Nick Simicich 2001-08-28 11:19:05 EDT
This bug is marked as a duplicate of a privare bug.  According to 
mharris@redhat.com, we should notify you of this so that you can either unmark 
51033 or reopen this bug, or put the resolution here.
Comment 5 Need Real Name 2001-09-06 22:41:00 EDT
I have the same bug, but the solution of tkmame@retrogames.com do not work at
all.
I have a P3 550 MHz with a Olidata Monitor (I didn't find the OLIxxxx in the
menu)
Comment 6 Mike A. Harris 2001-09-07 08:40:47 EDT
Fixed in XFree86-4.1.0-1 and later.  Current version is -3.

Note You need to log in before you can comment on or make changes to this bug.