This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 524716 - circular obsoletes in RHEL Server 5.4
circular obsoletes in RHEL Server 5.4
Status: CLOSED DUPLICATE of bug 523135
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openib (Show other bugs)
5.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-21 16:53 EDT by Jim White
Modified: 2009-11-20 15:48 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 451638
Environment:
Last Closed: 2009-11-20 15:48:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim White 2009-09-21 16:53:41 EDT
Problem:  When updating a 5.4 system from RHN, we experience a
          circular dependency issue between three packages and their
          replacements.

Details:

-------------------------------------------------------------------------------
On one pass, three "openib" packages are updated:
-------------------------------------------------------------------------------

Running Transaction
  Installing     : perftest                                                 1/6
  Installing     : mstflint                                                 2/6
  Installing     : tvflash                                                  3/6
  Erasing        : openib-perftest                                          4/6
  Erasing        : openib-mstflint                                          5/6
  Erasing        : openib-tvflash                                           6/6
Installed:
  mstflint.x86_64 0:1.4-1.el5            perftest.x86_64 0:1.2-14.el5
  tvflash.x86_64 0:0.9.0-2.el5
Replaced:
  openib-mstflint.x86_64 0:1.2-6.el5_1.1
  openib-perftest.x86_64 0:1.2-6.el5_1.1  openib-tvflash.x86_64 0:0.9.2-6.el5_1.1

-------------------------------------------------------------------------------
On the next pass, this is reversed:
-------------------------------------------------------------------------------

Running Transaction
  Installing     : openib-tvflash                                           1/6
  Installing     : openib-mstflint                                          2/6
  Installing     : openib-perftest                                          3/6
  Erasing        : tvflash                                                  4/6
  Erasing        : mstflint                                                 5/6
  Erasing        : perftest                                                 6/6

Installed:
  openib-mstflint.x86_64 0:1.2-6.el5_1.1
  openib-perftest.x86_64 0:1.2-6.el5_1.1
  openib-tvflash.x86_64 0:0.9.2-6.el5_1.1

Replaced:
  mstflint.x86_64 0:1.4-1.el5            perftest.x86_64 0:1.2-14.el5
  tvflash.x86_64 0:0.9.0-2.el5

-------------------------------------------------------------------------------

The above cycle repeats on subsequent upgrade attempts.
Comment 1 Guy Streeter 2009-11-20 15:48:54 EST

*** This bug has been marked as a duplicate of bug 523135 ***

Note You need to log in before you can comment on or make changes to this bug.