Bug 524720 - bad md5 regenerating selinux-policy, selinux-policy-targeted
Summary: bad md5 regenerating selinux-policy, selinux-policy-targeted
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-presto
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jonathan Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-21 21:07 UTC by John Reiser
Modified: 2009-10-07 09:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-07 09:11:49 UTC


Attachments (Terms of Use)

Description John Reiser 2009-09-21 21:07:28 UTC
Description of problem: A "yum update" failed the presto part on selinux-policy and selinux-policy-targeted.


Version-Release number of selected component (if applicable):
yum-presto-0.6.1-1.fc12.noarch


How reproducible:


Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
-----
   <<snip>>
Downloading Packages:
Setting up and reading Presto delta metadata
rawhide/prestodelta                                      | 186 kB     00:04
Processing delta metadata
Download delta size: 1.4 M
(1/13): cjkuni-uming-fonts-0.2.20080216.1-26.fc12_0.2.20 |  18 kB     00:01
(2/13): dhclient-4.1.0p1-8.fc12_4.1.0p1-9.fc12.i686.drpm | 260 kB     00:02
(3/13): gnome-bluetooth-2.27.90-3.fc12_2.28.0-1.fc12.i68 | 145 kB     00:02
(4/13): gnome-bluetooth-libs-2.27.90-3.fc12_2.28.0-1.fc1 |  17 kB     00:00
(5/13): libcanberra-0.17-2.fc12_0.18-1.fc12.i686.drpm    |  11 kB     00:00
(6/13): libcanberra-gtk2-0.17-2.fc12_0.18-1.fc12.i686.dr |  18 kB     00:00
(7/13): libsemanage-2.0.38-1.fc12_2.0.38-2.fc12.i686.drp |  42 kB     00:01
(8/13): libsemanage-python-2.0.38-1.fc12_2.0.38-2.fc12.i |  35 kB     00:02
(9/13): nss-3.12.4-8.fc12_3.12.4-9.fc12.i686.drpm        |  44 kB     00:01
(10/13): nss-tools-3.12.4-8.fc12_3.12.4-9.fc12.i686.drpm | 233 kB     00:02
(11/13): selinux-policy-3.6.32-6.fc12_3.6.32-7.fc12.noar | 129 kB     00:01
(12/13): selinux-policy-targeted-3.6.32-6.fc12_3.6.32-7. | 420 kB     00:04
(13/13): xorg-x11-drv-nouveau-0.0.15-10.20090914git1b720 |  17 kB     00:02
Finishing rebuild of rpms, from deltarpms
/var/cache/yum/i386/11.91/rawhide/deltas/selinux-policy-3.6.32-6.fc12_3.6.32-7.fc12.noarch.drpm: md5 mismatch of result
/var/cache/yum/i386/11.91/rawhide/deltas/selinux-policy-targeted-3.6.32-6.fc12_3.6.32-7.fc12.noarch.drpm: md5 mismatch of result
<delta rebuild>                                          |  12 MB     02:00
Error rebuilding rpm from selinux-policy-3.6.32-6.fc12_3.6.32-7.fc12.noarch.drpm! Will download full package.
Error rebuilding rpm from selinux-policy-targeted-3.6.32-6.fc12_3.6.32-7.fc12.noarch.drpm! Will download full package.
Presto reduced the update size by 76% (from 12 M to 3.0 M).
Package(s) data still to download: 8.0 M
(1/5): cjkuni-fonts-ghostscript-0.2.20080216.1-27.fc12.n | 9.7 kB     00:00
(2/5): cjkuni-ukai-fonts-0.2.20080216.1-27.fc12.noarch.r | 7.9 MB     00:03
(3/5): mailcap-2.1.30-1.fc12.noarch.rpm                  |  24 kB     00:00
(4/5): selinux-policy-3.6.32-7.fc12.noarch.rpm           | 424 kB     00:00
(5/5): selinux-policy-targeted-3.6.32-7.fc12.noarch.rpm  | 1.7 MB     00:00
--------------------------------------------------------------------------------
Total                                           833 kB/s |  10 MB     00:12
-----

Expected results: successful presto of selinux-policy and selinux-policy-targeted


Additional info:

Comment 1 Jonathan Dieter 2009-09-22 14:38:35 UTC
This is a problem with xz compression not being reproducible across architectures.  See http://www.mail-archive.com/fedora-devel-list@redhat.com/msg08013.html (though, it turns out that noarch packages are actually built on all architectures, so there will be random md5 checksum failures for all noarch packages, depending on which system they were built on).

I'm not sure how to fix this, as there's no way to fix deltarpm to deal with this problem.  The only solutions are in changing how the buildsystem works.

Comment 2 Jonathan Dieter 2009-10-07 09:11:49 UTC
xz has been fixed upstream (and in Rawhide) so that it generates exactly the same output whether on big-endian and little-endian architectures.


Note You need to log in before you can comment on or make changes to this bug.