Bug 524739 - setroubleshoot: SELinux is preventing the /usr/bin/kdm from using potentially mislabeled files (.Xauthority).
Summary: setroubleshoot: SELinux is preventing the /usr/bin/kdm from using potent...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:9b118312374...
: 524740 524741 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 02:07 UTC by FAMM
Modified: 2009-09-22 02:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-22 02:57:04 UTC
Type: ---


Attachments (Terms of Use)

Description FAMM 2009-09-22 02:07:50 UTC
The following was filed automatically by setroubleshoot:

Resúmen:

SELinux is preventing the /usr/bin/kdm from using potentially mislabeled files
(.Xauthority).

Descripción Detallada:

SELinux has denied kdm access to potentially mislabeled file(s) (.Xauthority).
This means that SELinux will not allow kdm to use these files. It is common for
users to edit files in their home directory or tmp directories and then move
(mv) them to system directories. The problem is that the files end up with the
wrong file context which confined applications are not allowed to access.

Permitiendo Acceso:

If you want kdm to access this files, you need to relabel them using restorecon
-v '.Xauthority'. You might want to relabel the entire directory using
restorecon -R -v ''.

Información Adicional:

Contexto Fuente               system_u:system_r:xdm_t:s0-s0:c0.c1023
Contexto Destino              unconfined_u:object_r:xauth_home_t:s0
Objetos Destino               .Xauthority [ file ]
Fuente                        kdm
Dirección de Fuente          /usr/bin/kdm
Puerto                        <Desconocido>
Nombre de Equipo              (removed)
Paquetes RPM Fuentes          kdm-4.3.1-4.fc12
Paquetes RPM Destinos         
RPM de Políticas             selinux-policy-3.6.32-6.fc12
SELinux Activado              True
Tipo de Política             targeted
MLS Activado                  True
Modo Obediente                Enforcing
Nombre de Plugin              home_tmp_bad_labels
Nombre de Equipo              (removed)
Plataforma                    Linux (removed) 2.6.31-33.fc12.i686 #1 SMP Thu
                              Sep 17 15:56:11 EDT 2009 i686 i686
Cantidad de Alertas           1
Visto por Primera Vez         lun 21 sep 2009 18:33:35 CDT
Visto por Última Vez         lun 21 sep 2009 18:33:35 CDT
ID Local                      9d9cd5c7-6082-438d-932c-e4060052cae9
Números de Línea            

Mensajes de Auditoría Crudos 

node=(removed) type=AVC msg=audit(1253576015.442:18): avc:  denied  { unlink } for  pid=1343 comm="kdm" name=".Xauthority" dev=sda1 ino=10166 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:xauth_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253576015.442:18): arch=40000003 syscall=10 success=no exit=-13 a0=bf8e945c a1=0 a2=bf8e945c a3=bf8e905a items=0 ppid=1317 pid=1343 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t xauth_home_t:file unlink;

Comment 1 Daniel Walsh 2009-09-22 02:57:04 UTC
A kdebase update was just made that should fix this in rawhide.

Comment 2 Daniel Walsh 2009-09-22 02:57:30 UTC
*** Bug 524740 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2009-09-22 02:58:04 UTC
*** Bug 524741 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.