Bug 524756 - ata[n]: SRST failed (errno=-16)
Summary: ata[n]: SRST failed (errno=-16)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 04:13 UTC by Razvantin
Modified: 2009-12-01 04:44 UTC (History)
7 users (show)

Fixed In Version: 2.6.30.9-99.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 04:44:36 UTC


Attachments (Terms of Use)
Log 1 (63.77 KB, text/plain)
2009-09-28 17:59 UTC, Razvantin
no flags Details
Log 2 (69.61 KB, text/plain)
2009-09-28 18:05 UTC, Razvantin
no flags Details
Log 3 (64.94 KB, text/plain)
2009-09-28 18:09 UTC, Razvantin
no flags Details
Log 4 (65.77 KB, text/plain)
2009-09-28 18:12 UTC, Razvantin
no flags Details
[24 nov 09] - Install Kernell 2.6.30.9-99 (79.28 KB, application/octet-stream)
2009-11-24 11:36 UTC, Razvantin
no flags Details
[24 nov 09] - Live CD (69.42 KB, application/octet-stream)
2009-11-24 11:39 UTC, Razvantin
no flags Details
[24 nov 09] - Normal Boot Again (65.51 KB, application/octet-stream)
2009-11-24 11:42 UTC, Razvantin
no flags Details


Links
System ID Priority Status Summary Last Updated
Linux Kernel 13575 None None None Never
Red Hat Bugzilla 438266 None CLOSED [libata config disk] 2.6.24.* SATA and ACPI errors not in 2.6.23.* 2018-09-18 03:25:27 UTC
Red Hat Bugzilla 490547 None CLOSED Boot is failing due to harddisk error: SRST failed (errno=-16) 2018-09-18 03:25:27 UTC

Description Razvantin 2009-09-22 04:13:09 UTC
Description of problem:
When i boot a live CD, just before the start screen i get ata3: SRST failed (errno=-16)
This way i can't find my HDD when trying to install.

Downloaded ISO's checksum is ok.
Burned at 8x speed.
RAID is disabled.
HDD is on ata1 slot.
HDD has no "cable select" jumper setting.
Jumper on 1.5gb/s has no effect.


Version-Release number of selected component (if applicable):
i just guessed the component as suggested by the site. i am guessing the component has to do with finding HDDs...


How reproducible:
100%

Steps to Reproduce:
1.boot Fedora 11 Live CD
2.
3.
  
Actual results:
Failing to detect my HDD

Expected results:
ata3: SRST failed (errno=-16)

Additional info:

I made Fedora work at a point. 
I had two windows xp partitions, c and d, with the system being installed on D:\. I used C:\ to make the whole linux partition structure. Before the installation finished, i chose D:\ with WinXP on, as path for the boot loader. This way i lost my Xp system but Fedora was looking good. I've update it and reboot it several times.
I set up some widgets and turned the computer off.

Next thing in the morning i got that SRST failed again. I formated all partitions into one big chunk using Xp install CD, at that point, the only CD that could detect my HDD.

I was suggested to try and switch off HDD's powersave feature with hdparam -Z but this only returns:
disabling Seagate auto powersaving mode
HDIO_DRIVE_CMD(seagatepwrsave) failed: Invalid exchange 

At this moment, my HDD has one partition with a fully operational WinXP but my live CD does not see my HDD anymore.

My hardware configuration is
PCC: Pentium D 945 3400mhz, fsb 800mhz
MB:  nForce 680i
RAM: 2x A-data 1gb ddr2 @800mhz
VB:   9800 GT 1gb
HDD: Seagate Barracuda 7200.10 sata2 320gb

Comment 1 Razvantin 2009-09-23 00:05:38 UTC
Can someone change The Severity to "High":
"Severity Two issues are defined as high-impact issues." Fedora 11 is unusable.
"The customer's operation is disrupted," I lost data trying to recover the partition, and time installing programs that got lost due to this error.
"but there is some capacity to produce." only live CD'ing.

don't mean to annoy anyone nagging. i know you are pretty busy being involved in this project ... and most of all you are doing it for "free as in freedom"... 
more over, i do intend to commit and contribute to fedora project by promoting your work and expose it to my local business environment in any way i can.

Comment 2 Kevin Fenzi 2009-09-24 19:54:54 UTC
This is a kernel issue, re-assigning it over to kernel.

Comment 3 Razvantin 2009-09-24 20:30:54 UTC
I now checked the Live CD after you asked me to on IRC ...

this time i didn't received the SRST failed and Installer found my HDD.

I will fresh install fedora 11 on my hdd ... but i am expecting the OS to fail again after a while. I already stated i made Fedora work once before, only to have it SRST failed crush again...

I did the same with xubuntu several month ago
http://ubuntuforums.org/showthread.php?t=1192050
The thread reached 2900 views by now and no one is being able to solve this problem i am experiencing :(

xp > linux > srst eror > xp > linux and so on ...

my system is in the > linux phase since the live CD started to see my HDD again.
I only installed Windows XP and some drivers/programs since my last SRST failed under live CD ...

Comment 4 Chuck Ebbert 2009-09-25 03:39:19 UTC
We really need to see the entire kernel boot log when that happens. If it happens again, remove 'rhgb quiet' from the boot options and try to get at least the messages before and after the SRST failure.

Comment 5 Razvantin 2009-09-28 17:59:57 UTC
Created attachment 362926 [details]
Log 1

This is the log before i sent Fedora 11 into "SRST failed (errno=-16)

Comment 6 Razvantin 2009-09-28 18:01:34 UTC
Comment on attachment 362926 [details]
Log 1

System was good. This is the log created just before i sent Fedora 11 into "SRST failed (errno=-16)

Comment 7 Razvantin 2009-09-28 18:05:38 UTC
Created attachment 362928 [details]
Log 2

This log was peeked using a Live CD, since Fedora now started to jam moments after the progress bar at start up finished loading.
The "SRST failed errno=-16" is shown within this log.

Comment 8 Razvantin 2009-09-28 18:09:14 UTC
Created attachment 362929 [details]
Log 3

This recorded log is made from a Live CD, after the HDD has been made "visible" by installing the drivers in Windows XP, witch was on another partition.
At this point, Fedora 11 can now be installed again

Comment 9 Razvantin 2009-09-28 18:12:28 UTC
Created attachment 362931 [details]
Log 4

This is the log captured just after the newly installed Fedora 11 loaded up.
Comparing it to Log 1, i found that the only difference is that some hardware identification processes ware done in another order.

Comment 10 Razvantin 2009-09-28 18:40:11 UTC
Actions that make Fedora go "SRST failed (errno=-16):
Suspend to RAM
Suspend to Disk
Shutdown Computer for several hours



Repeating the Cycle:

HDD Partitionin Configuration used:
[C:] ntfs - partition used to host Windows XP sp2
[\boot] ext3
[\] ext4 
[swap] swap

Session 1 - Triggering the event
-Start up Fedora
{recorded lspci and dmesg in file "Log 1"}
-Suspend to Disk/RAM

Session 1a - Fedora is of this point jammed
-Resume Fedora
{after start-up progress bar compleats, a bleeping upper-left corner "_"
underscore is displayed, system jammes}
-Reset
{subsequent session of Fedora 11 start-ups now will produce the same results
over again}

Session 1a - I used Live CD to record what was going on
-Boot Live CD
{Live Boot Slow >5 min}
{recorded lspci and dmesgin file "Log 2"}
-Restart

Session 2 - Installing the needed drivers under Windows to make HDD visible for
Live CD again
-Start up Windows XP
-Install MB drivers {drivers details listed below}
-Restart

Session 2a - Reloading Windows for the Drivers changes made to take effect
-Start up Windows XP
-Restart

Session 3 - Installing Fedora 11 again
-Boot Live CD
{recorded lspci and dmesg in file "Log 3"}
-Install Fedora 11 using manual configuration to reassign mounting point for the
existant partitions.
-Restart

Session 3a - Finishing Instalation of Fedora 11 onto HDD
-Start up Fedora[new]
-Continue Instalation until finished
{recorded lspci and dmesg in file "Log 4"}



One of this Drivers under Windows XP made HDD recognisable by Fedora 11 live CD

I.NVIDIA SMBus Driver
II.NVIDIA Ethernet Driver
III.NVIDIA Storage Driver*
IV.NVIDIA and ForceWare Network Access Manager**

*The NVIDIA Storage driver consists of 3 components:
1) NVIDIA storage driver optimized for nForce SATA controller that will replace
the driver that came with Windows.
2) A RAID controller driver which is required if SATA RAID is ENABLED in BIOS
3) RAID Manager application software

**The NVIDIA and ForceWare Network Access Manager consists of 3 components:
1)Network Access Manager's Framework
2)NVIDIA control panel
3)Intelligent Application Manager



Possible Causes
An unavaileble Linux equivalent of the NV121906 hotfix

Quote: "Some NVIDIA nForce 680i SLI "Designed by NVIDIA" motherboard customers have
reported experiencing disconnect or write error issues with SATA disk drives. To
address this, NVIDIA has released a BIOS update for the NVIDIA nForce 680i SLI
"Designed by NVIDIA" motherboards that eliminates this bug."
Source: http://www.nvidia.com/object/680i_hotfix.html

The fix was called "NV121906" and the links provided on the site are now broken, probably because the problems are now adressed in Windows Vista sp1.
http://www.nvidia.com/object/windows_vista_hotfixes.html

I found some update drivers on NVIDIA's site, but i am affraid to use it [i'm kind'a noob to linux, and the file extension within the package scares me. I hope it is not a flash update cuz' last time i did a flash update i ended up frying my motherboard]
http://www.nvidia.com/object/linux_nforce_1.25.html
Is sata_nv.c included in Fedora 11 installation already?

I want to thank linux_o for bringing me into Fedora community when i was struggling with xUbuntu. Fedora proved to be more of an inspiring medium then Ubuntu... 
And though i had the same problems as before, he did hint me about the hotfix NVIDIA was having for windows...

Comment 11 Razvantin 2009-09-29 02:08:40 UTC
Further findings:

Guaranteed things that trigger the bug:
Powering off HDD for less then 1 minute.
Suspending to Disk
Suspending to RAM


Partial Solution
1.Have a fail-safe Windows XP Operating System installed on a separate partition.
2.Each time the Error occurs, boot Windows XP and install "NVIDIA Storage Driver" that came with the Mother Board, weather you have it installed already or not.
3.Reboot windows Xp so that the changes can take effect.

Fedora 11 will now boot once again without any loss of data.

The only problem is that you will repeat this actions each time you power off/suspend to Disk/Suspend to RAM
Also, Bootloader Menu might go blank [though not jam itself] and you would have to guess witch boot you chose.

Will a proper hotfix come in a new update soon?

Comment 12 Razvantin 2009-10-03 15:41:56 UTC
I posted the entire kernel boot log during all cycles of this bug ... as requested by Chuck Ebbert.

Also, Kevin Fenzi mentioned something about re-assigning the issue over to kernel. the component in question on this bug log was selected to "kernel"... was i suggested to head over to a new forum witch is new to me or all checks are go and i should wait for a reply soon?

I mean i check this thread about 3 times a day and i only got a reply from those guys... is anything happening? it took me one night and a day to repeat the cycles until i figured out what was going on. I narrowed the guesses down as much as i could. This bug is now 100% probable giving the system configuration above..

guys? ...

Comment 13 Kevin Fenzi 2009-10-03 20:53:40 UTC
Please be patient. Keep in mind that there are around 1300 kernel bugs open, and only a few kernel maintainers to deal with them all. 

This bug is assigned in the right place from what I can tell.

Hopefully one of the kernel guys will have ideas on what to try next.

Comment 14 Chuck Ebbert 2009-10-08 13:59:46 UTC
Don't add me to kernel bug cc: lists. I already get all the mail to the kernel-maint address.

Comment 15 Chuck Ebbert 2009-10-08 14:06:33 UTC
Did you try the 2.6.30.8-64 kernel?

Comment 16 Razvantin 2009-10-08 14:57:03 UTC
srry cebbert for cc ... 

i tried all the kernels ... except any kernel might be available within the past 8 days. I am away from my new computer and use an older one instead since i recently moved out and most of luggage is still at my parent's house.

Comment 17 Chuck Ebbert 2009-10-13 12:52:15 UTC
Looks like this was fixed in 2.6.31.4. The same fix is now in 2.6.30.9-84.fc11

Comment 18 Razvantin 2009-10-14 14:35:45 UTC
is 2.6.31.4 in rawhide now? i've been updating for the last days and didn't get my kernel at that...


also, i've discovered that all i need to do to boot linux is boot xp first... i've also noticed that xp takes a lot longer to shut down when that thing that's making the SRST failed is activated...

Comment 19 Fedora Update System 2009-10-18 01:56:22 UTC
kernel-2.6.30.9-90.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.30.9-90.fc11

Comment 20 Razvantin 2009-10-19 06:24:36 UTC
omg ... cebert is writing it. it's an honour to meet a kernel writer ... 
srry, i am used to windows style where i just sit and wait for updates and share my problems with other people on forums that no one ever reads anyway... 

i'm so in love with this project ... 

can't wait to try it :)

Comment 21 Razvantin 2009-10-25 16:44:44 UTC
just tried out 
2.6.9-90.fc11.x86-64
and .. still getting those errors ... the pattern is the same.

the only thing that's missing from the update package system is the rawhide...

Comment 22 Fedora Update System 2009-10-27 06:46:17 UTC
kernel-2.6.30.9-90.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Razvantin 2009-10-27 17:38:11 UTC
problem still persists ..

the system is showing the same patterns ... do you want me to dmesg log files again?

have i not installed it right? i used the update package manager and ticked anything except the rawhide codes ...

no updates are showing. os is up to date i guess ...

Comment 24 Chuck Ebbert 2009-11-18 00:31:45 UTC
More fixes from upstream 2.5.31.6 are in 2.6.30.9-98.fc11

Comment 25 Fedora Update System 2009-11-18 12:17:07 UTC
kernel-2.6.30.9-99.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kernel-2.6.30.9-99.fc11

Comment 26 Fedora Update System 2009-11-20 05:27:51 UTC
kernel-2.6.30.9-99.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-11803

Comment 27 Razvantin 2009-11-24 11:36:59 UTC
Created attachment 373386 [details]
[24 nov 09] - Install Kernell 2.6.30.9-99

This is what i got after installing the new kernel, just before shut down.

Comment 28 Razvantin 2009-11-24 11:39:01 UTC
Created attachment 373387 [details]
[24 nov 09] - Live CD

This is what i got after a failed boot ... during a live CD session

Comment 29 Razvantin 2009-11-24 11:42:32 UTC
Created attachment 373390 [details]
[24 nov 09] - Normal Boot Again

after booting windows Xp first, then normal boot Fedora.

Comment 30 Razvantin 2009-11-24 11:57:13 UTC
So i did this...

Session 1 - Installing new kernel.
{recorded lspci and dmesg in file "[24 nov 09] - Install Kernell 2.6.30.9-99"}
-Shut Down

Session 1a - Fedora is of this point jammed
-Resume Fedora
{after start-up progress bar compleats, a bleeping upper-left corner "_"
underscore is displayed, system jammes}
-Reset
{subsequent session of Fedora 11 start-ups now will produce the same results
over again ... as before}

Session 2 - I used Live CD to record what was going on
-Boot Live CD
{recorded lspci and dmesgin file "[24 nov 09] - Live CD"}
-Restart

Session 3 - I used win XP to "miraculously" fix Fedora11 
-Boot WinXP
-Restart

Session 4 - Normal boot fedora.
-Boot Fedora 11
{recorded lspci and dmesgin file "[24 nov 09] - Normal Boot Again"}

Comment 31 Razvantin 2009-11-24 11:58:28 UTC
The new kernel show same patterns... losing track of the hdd if i either Shut it Down or Suspend my pc...

Comment 32 Fedora Update System 2009-12-01 04:44:18 UTC
kernel-2.6.30.9-99.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.