Bug 524761 - Keyboard and mouse of rhel3.9-32 guest with smp kernel are abnormal after migration.
Summary: Keyboard and mouse of rhel3.9-32 guest with smp kernel are abnormal after mig...
Keywords:
Status: CLOSED DUPLICATE of bug 555649
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Juan Quintela
QA Contact: Lawrence Lim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 05:27 UTC by Qunfang Zhang
Modified: 2014-03-26 01:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-28 01:29:16 UTC


Attachments (Terms of Use)

Description Qunfang Zhang 2009-09-22 05:27:22 UTC
Description of problem:
After migrated the rhel3.9-32 guest with smp kernel, the mouse and keyboard are abnormal. For example, I input the command "ls" in the terminal, but it will display "llllllssssss". And also when I right-click mouse on the desktop of guest to create a "New Window" or "New Folder", two or more windows or folders will be created rapidly.

And the issue does not occurs every time, when implement ping-pong migration it will be more easy to reproduce.


Version-Release number of selected component (if applicable):
kvm-83-105.el5_4.4
kernel-2.6.18-164.el5

How reproducible:
Not everytime but always

Steps to Reproduce:
1.Install a rhel3.9-32 guest and install smp kernel.
2.Boot rhel3.9-32 guest with smp kernel on source host and also on destination host with listening mode.
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -smp 4 -m 4G -net nic,vlan=0,macaddr=00:1a:4a:01:22:39,model=rtl8139 -net tap,vlan=0,script=/etc/qemu-ifup -drive file=/mnt/rhel3.9-32-smp.raw,media=disk,if=ide,index=0 -cpu qemu64,+sse2 -uuid c8647283-4f32-4d9c-a8be-a37d6edd2cd2 -monitor stdio -vnc :10 -boot c(-incoming tcp:0:5800)
3.Implement ping-pong migration for about 3 times.
4.Open a terminal in the guest and input "ls".
5.Implement migration again if this issue cannot reproduce. 
  
Actual results:
In the terminal of guest, "lllllssssss" will display

Expected results:
In the terminal of guest "ls" command display.

Additional info:
Guest kernel: 
kernel-smp-2.4.21-60.EL.i686

Host info:
processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Quad CPU    Q9550  @ 2.83GHz
stepping	: 10
cpu MHz		: 2826.233
cache size	: 6144 KB
physical id	: 0
siblings	: 4
core id		: 3
cpu cores	: 4
apicid		: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx smx est tm2 cx16 xtpr lahf_lm
bogomips	: 5652.49
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

Comment 2 Juan Quintela 2010-01-28 01:29:16 UTC
kvm has problem with rhel3 & smp.  Investigating problem on bug  555649.

*** This bug has been marked as a duplicate of bug 555649 ***


Note You need to log in before you can comment on or make changes to this bug.