Bug 524779 - libvirt: error: Failed to reboot domain on kvm
libvirt: error: Failed to reboot domain on kvm
Status: CLOSED DUPLICATE of bug 496537
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On: 495479
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-22 03:06 EDT by zhanghaiyan
Modified: 2009-10-02 05:22 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 495479
Environment:
Last Closed: 2009-10-02 05:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhanghaiyan 2009-09-22 03:06:40 EDT
Description of problem:
Error messages occurs when rebooting guest domain.

Version-Release number of selected component (if applicable):
- libvirt-0.7.1-4.fc12.x86_64
- qemu-kvm-0.10.91-0.5.rc1.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. define a guest domain from xml
2. # virsh start kvmtest
3. # virsh reboot kvmtest
  
Actual results:
Failed to reboot the guest domain, the command output:
error: Failed to reboot domain kvmtest
error: this function is not supported by the hypervisor: virDomainReboot

Expected results:
The guest domain can be rebooted successfully.

Additional info:
shutdown and destroy operation are normally.


+++ This bug was initially created as a clone of Bug #495479 +++

Description of problem:
The following error messages occurs when rebooting guest domain.
--------------------
error: Failed to reboot domain kvmtest
error: this function is not supported by the hypervisor: virDomainReboot
--------------------

Version-Release number of selected component (if applicable):
rhel5u3: 2.6.18-128.el5
kvm-83-27.el5ovirt
libvirt-0.6.2-1.el5

How reproducible:
Always

Steps to Reproduce:
1. define a guest domain from xml
2. # virsh start kvmtest
3. # virsh reboot kvmtest
  
Actual results:
Failed to reboot the guest domain.

Expected results:
The guest domain can be rebooted successfully.

Additional info:
shutdown and destroy operation are normally.

--- Additional comment from veillard@redhat.com on 2009-04-22 08:30:46 EDT ---

Yes, as far as I can tell this won't be supported in 0.6.3, QEmu has no support
for a 'reboot' operation, only shutdown. This could be worked around in libvirt
but that would be made with "shutdown and start", not exactly equivalent to
a reboot at the QEmu level though.

So not for 5.4, maybe in 5.5, either though QEmu or via a libvirt workaround.

Daniel

--- Additional comment from berrange@redhat.com on 2009-06-19 07:13:02 EDT ---

Yep, this is a current limitation of QEMU, so fixing this is blocked on getting the RFE in QEMU.
Comment 1 Mark McLoughlin 2009-10-02 05:22:45 EDT

*** This bug has been marked as a duplicate of bug 496537 ***

Note You need to log in before you can comment on or make changes to this bug.