Bug 524798 - system won't sleep when screen locked
Summary: system won't sleep when screen locked
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 569490 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 08:53 UTC by Ellen Shull
Modified: 2010-03-01 18:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-01 18:14:48 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 209511 0 None None None Never

Description Ellen Shull 2009-09-22 08:53:49 UTC
Description of problem:
If lid is closed with screen in locked state, system won't sleep (suspend to ram).  Given that by default settings in powersave profile, system comes out of sleep in locked screen, means can't put it back to sleep until you've unlocked screen.

Version-Release number of selected component (if applicable):
kdebase-workspace-4.3.1-1.fc11.x86_64 (guessing at component)

How reproducible:
always

Steps to Reproduce:
* close lid, system sleeps
* open lid, system wakes in a locked-screen state
* close lid again...  system doesn't sleep

Additional info:
If you unlock screen, then it'll go back to sleep...  but what if you accidentally popped latch on lid, or started to open then changed your mind...  or somebody else screwed with laptop...

IBM ThinkPad T60p, in case it's just me--but otherwise this machine has worked brilliantly under F11/KDE.

Comment 1 Rex Dieter 2009-09-24 12:51:39 UTC
This bug should be punted upstream.

I vaguely recall a report recently very similar to this for which we already did that, but I can't seem to find it atm.

Comment 2 Steven M. Parrish 2009-10-02 09:04:47 UTC
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Rex Dieter 2010-03-01 16:01:57 UTC
*** Bug 569490 has been marked as a duplicate of this bug. ***

Comment 4 Rex Dieter 2010-03-01 16:09:18 UTC
rebasing to F-12

Comment 5 Michael Ploujnikov 2010-03-01 18:04:06 UTC
Upstream bug opened: https://bugs.kde.org/show_bug.cgi?id=209511

Comment 6 Rex Dieter 2010-03-01 18:13:51 UTC
Thanks.

Comment 7 Rex Dieter 2010-03-01 18:14:48 UTC
let's continue to track this one upstream.


Note You need to log in before you can comment on or make changes to this bug.