Bug 52485 - Installer hangs at partition check
Installer hangs at partition check
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2001-08-24 01:17 EDT by Bill Montana
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Montana 2001-08-24 01:17:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en]C-{C-UDP; EBM-Fujitsu1}  (Win98; U)

Description of problem:
I'm trying to install 7.1 as an upgrade to 6.1 using the hard disk installation method. Linux loads and begins to probe the hardware. It hangs 
during the partition check. I have tried using hda=noprobe as well as hda=nodma. Using the noprobe option, the installation progresses but 
thinks there are no hard disks in the system. Nodma has no effect. Here are the startup messages from the point of probing IDE:

Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt82c586a (rev 25) IDE UDMA33 controller on pci00:07.1
    ide0: BM-DMA at 0x6000-0x6007, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0x6008-0x600f, BIOS settings: hdc:pio, hdd:pio
hda: Maxtor 52049U4, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 40020624 sectors (20491 MB) w/2048KiB Cache, CHS=2491/255/63, UDMA(33)
Partition check:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot from boot disk (boot.img)
2. Wait

Actual Results:  System hangs

Expected Results:  Installation should continue

Additional info:

Pentium 200, 64Mb RAM, Maxtor 20Gb hard drive
Comment 1 Arjan van de Ven 2001-08-24 17:38:07 EDT
hda=nodma doesn't do a thing; it's "ide=nodma"; could you try that ?
Comment 2 Bill Montana 2001-08-26 00:56:47 EDT
it's "ide=nodma"; could you try that ?; Yes, that is what I meant (I tried it again, anyway).
Comment 3 Arjan van de Ven 2001-08-26 09:33:50 EDT
Strange. Weird question: does it happen too if you connect your CDROM to the
same cable as the disk ? It appears that your CDROM is currently a slave on a
cable without master.....

Comment 4 Bill Montana 2001-08-31 13:42:43 EDT
does it happen too if you connect your CDROM to the same cable as the disk? ; It would not boot at all with the CD-ROM connected using the same 
cable as the disk. So, I disconnected the CD-ROM altogether and got the same results as before. It hangs at the partition check. Sometimes it 
shows a few partitions and sometimes it does not before hanging.
Comment 5 Bill Montana 2001-08-31 13:48:55 EDT
I noticed in the BIOS that the disk is in LBA mode. Is this ok? Should it be in Normal or Large mode? If I change it to a different mode, will data loss 
Comment 6 Arjan van de Ven 2001-09-06 04:53:56 EDT
Bios settings are irrelevant other that for getting LILO and the first few "....
 in teh kernel boot.

My guess REALLY is that either the cable is daft, or that the drive is jumpered
incorrectly, given that putting the CDROM on the same cable makes it worse.
Also, if it's a 80 ribbon cable, the master has a FIXED place on the IDE cable,
eg the endpoint.
Comment 7 Bill Montana 2001-09-06 23:56:45 EDT
given that putting the CDROM on the same cable makes it worse ; I had inadvertantly plugged the cable on the CD-ROM drive backwards. Anyway, disconnecting the CD-ROM drive completely did not change things either.

Also, if it's a 80 ribbon cable, the master has a FIXED place on the IDE cable ; the hard drive IS on the end of the IDE cable.

The drive is jumpered correctly (as Master/Single).

RH 6.1 installed to this hard drive without any problems (and with the CD-ROM as a slave on the other IDE controller).
Comment 8 Bill Montana 2001-10-09 15:28:36 EDT
It seems this is not an installer problem, but that RH 7.1 and my Maxtor drive 
are incompatible with one another. I disconnected the Maxtor drive and installed 
RH 7.1 on another drive, which went well. When I reconnected the Maxtor drive 
the RH 7.1 would not boot. It hangs at the partition check for hdb (the Maxtor 
drive). I guess I will have to buy another drive to replace the perfectly 
good Maxtor drive.

Any ideas about how to get this drive to work? I did a workstation install of RH 
6.1 on it about a year ago.
Comment 9 amol dixit 2004-02-01 02:24:37 EST
having same problem "instn stops at partn chk".
new laptop (HP ze5500 series), blank hdd...RH8 halts.
pls suggest a remedy.
Comment 10 mostafa berg 2004-04-27 09:48:28 EDT
Hi !!

well i tried all u said didnt work , although i had linux installed 
on the same machine and i didnt change anything but adding a CD 
writer on an other IDE CABLE , i disconnected it , but that didnt 
i disconneect the HARD disk , and the installation went fine !
im going maad !

any ideas? i've reset my mobo and that didnt help !

i dont know what changed !
Comment 11 Bugzilla owner 2004-09-30 11:39:08 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.