Bug 524867 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd "setattr" access on .abrt.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd "setattr" access on .abrt.
Keywords:
Status: CLOSED DUPLICATE of bug 522878
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:923f78df428...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 14:25 UTC by Moisés Ramos
Modified: 2009-09-22 15:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-22 15:10:18 UTC


Attachments (Terms of Use)

Description Moisés Ramos 2009-09-22 14:25:26 UTC
The following was filed automatically by setroubleshoot:

Resúmen:

SELinux is preventing /usr/sbin/abrtd "setattr" access on .abrt.

Descripción Detallada:

[abrtd has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Permitiendo Acceso:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Información Adicional:

Contexto Fuente               system_u:system_r:abrt_t:s0
Contexto Destino              system_u:object_r:user_home_dir_t:s0
Objetos Destino               .abrt [ dir ]
Fuente                        abrtd
Dirección de Fuente          /usr/sbin/abrtd
Puerto                        <Desconocido>
Nombre de Equipo              (removed)
Paquetes RPM Fuentes          abrt-0.0.8.5-1.fc12
Paquetes RPM Destinos         
RPM de Políticas             selinux-policy-3.6.32-7.fc12
SELinux Activado              True
Tipo de Política             targeted
MLS Activado                  True
Modo Obediente                Enforcing
Nombre de Plugin              catchall
Nombre de Equipo              (removed)
Plataforma                    Linux (removed) 2.6.31-33.fc12.x86_64 #1 SMP
                              Thu Sep 17 15:40:43 EDT 2009 x86_64 x86_64
Cantidad de Alertas           1
Visto por Primera Vez         mar 22 sep 2009 16:23:46 CEST
Visto por Última Vez         mar 22 sep 2009 16:23:46 CEST
ID Local                      bc63182b-8c68-4bc7-8fc9-b2feea688c51
Números de Línea            

Mensajes de Auditoría Crudos 

node=(removed) type=AVC msg=audit(1253629426.940:492): avc:  denied  { setattr } for  pid=1342 comm="abrtd" name=".abrt" dev=sda2 ino=8195 scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1253629426.940:492): arch=c000003e syscall=90 success=yes exit=0 a0=b8aeb8 a1=1c0 a2=ffffffffffffff88 a3=1 items=0 ppid=1 pid=1342 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0 key=(null)


audit2allow suggests:

#============= abrt_t ==============
allow abrt_t user_home_dir_t:dir setattr;

Comment 1 Daniel Walsh 2009-09-22 15:10:18 UTC

*** This bug has been marked as a duplicate of bug 522878 ***


Note You need to log in before you can comment on or make changes to this bug.