Bug 524887 - Fedora12: virt-install fails to install if selinux is enabled
Summary: Fedora12: virt-install fails to install if selinux is enabled
Keywords:
Status: CLOSED DUPLICATE of bug 521652
Alias: None
Product: Fedora
Classification: Fedora
Component: python-virtinst
Version: rawhide
Hardware: x86_64
OS: All
low
high
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 15:40 UTC by IBM Bug Proxy
Modified: 2009-10-02 09:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-02 09:25:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 56255 None None None Never

Description IBM Bug Proxy 2009-09-22 15:40:29 UTC
=Comment: #0=================================================
PAVAN NAREGUNDI <pavan.naregundi@in.ibm.com> - 
With selinux enabled installation of guest failed as shown below on Fedora12 rawhide.

===================
# virt-install -n f12alpha -r 500 --disk path=/home/f12.raw,bus=ide  --accelerate --vnc --os-type
linux --os-variant fedora12 -c /tmp/Fedora-12-Alpha-x86_64-disc1.iso 


Starting install...
ERROR    internal error unable to start guest: bind(unix:/var/lib/libvirt/qemu/f12alpha.monitor):
Permission denied
qemu: could not open monitor device 'unix:/var/lib/libvirt/qemu/f12alpha.monitor,server,nowait'

Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start f12alpha'; otherwise, please
 restart your installation.
ERROR    internal error unable to start guest: bind(unix:/var/lib/libvirt/qemu/f12alpha.monitor):
Permission denied
qemu: could not open monitor device 'unix:/var/lib/libvirt/qemu/f12alpha.monitor,server,nowait'
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 929, in <module>
    main()
  File "/usr/sbin/virt-install", line 825, in main
    start_time, guest.start_install)
  File "/usr/sbin/virt-install", line 880, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 628, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 726, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1077, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest:
bind(unix:/var/lib/libvirt/qemu/f12alpha.monitor): Permission denied
qemu: could not open monitor device 'unix:/var/lib/libvirt/qemu/f12alpha.monitor,server,nowait'
==============

virt-manager-0.8.0-3.fc12.noarch
python-virtinst-0.500.0-1.fc12.noarch
libvirt-0.7.1-1.fc12.x86_64
qemu-system-x86-0.10.92-1.fc12.x86_64


# uname -a
Linux elm3c55.beaverton.ibm.com 2.6.31-14.fc12.x86_64 #1 SMP Tue Sep 15 03:48:57 EDT 2009 x86_64
x86_64 x86_64 GNU/Linux


After disabling the selinux, guest install works fine.
      
=================================================
Hello Red Hat,

could you please help us on this issue?

It looks like a similar (if not the same) problem already reported in your RH Bugzilla against F11:
https://bugzilla.redhat.com/show_bug.cgi?id=515521

Please let us know if you need any additional information.

Thanks for your support.

Comment 1 Mark McLoughlin 2009-10-02 09:25:11 UTC

*** This bug has been marked as a duplicate of bug 521652 ***


Note You need to log in before you can comment on or make changes to this bug.