Bug 524894 - perl-PAR-Packer debuginfo is empty
perl-PAR-Packer debuginfo is empty
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl-PAR-Packer (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-09-22 12:06 EDT by Ville Skyttä
Modified: 2009-09-23 14:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 14:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2009-09-22 12:06:42 EDT
From http://kojipkgs.fedoraproject.org/packages/perl-PAR-Packer/0.991/3.fc12/data/logs/x86_64/build.log :

gcc static.o -s -Wl,-E [...]

Looks like the build strips binaries before rpmbuild has had a chance to do it.
Comment 1 Stepan Kasal 2009-09-23 14:17:24 EDT
The build process uses a built binary program (myldr/static) to create the parl and parldyn binaries before installing.
I cannot find any way to fix this; let it be until a perl-PAR expert appears.

(I set debug_package to %{nil) to prevent creating an empty debuginfo package.)

Note You need to log in before you can comment on or make changes to this bug.