Bug 524897 - PartitionException: Error opening /dev/md0: No such file or directory
Summary: PartitionException: Error opening /dev/md0: No such file or directory
Keywords:
Status: CLOSED DUPLICATE of bug 518990
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:a428f981792d92b6c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 16:41 UTC by Edward
Modified: 2009-09-22 17:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-22 17:24:30 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (756.10 KB, text/plain)
2009-09-22 16:41 UTC, Edward
no flags Details

Description Edward 2009-09-22 16:41:29 UTC
The following was filed automatically by anaconda:
anaconda 12.15-1.fc12 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/__init__.py", line 293, in freshDisk
    peddisk = disk_new_fresh(device.getPedDevice(), ty)
  File "/usr/lib/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in freshDisk
  File "/usr/lib/anaconda/storage/devices.py", line 760, in partedDisk
    ty = platform.getPlatform(None).diskType)
  File "/usr/lib/anaconda/storage/devices.py", line 735, in __init__
    if self.partedDisk:
  File "/usr/lib/anaconda/storage/devicetree.py", line 1161, in addUdevDiskDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1254, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1864, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 74, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1201, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartitionException: Error opening /dev/md0: No such file or directory

Comment 1 Edward 2009-09-22 16:41:36 UTC
Created attachment 362120 [details]
Attached traceback automatically from anaconda.

Comment 2 Denise Dumas 2009-09-22 16:53:44 UTC
Original summary - Tried to install FC12 Alpha with Raid 5 with LVM, then when i went to the next screen i got an error because the installer could not format the first hard drive. The installer crashed and poped up with fatal error 1 and no way to send the error to Bugzill

Comment 3 Chris Lumens 2009-09-22 17:24:30 UTC

*** This bug has been marked as a duplicate of bug 518990 ***


Note You need to log in before you can comment on or make changes to this bug.