Bug 52492 - openssl errata breaks mod_ssl (under some circumstances)
openssl errata breaks mod_ssl (under some circumstances)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 06:16 EDT by Vidar Langseid
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 06:16:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidar Langseid 2001-08-24 06:16:18 EDT
Description of Problem:

If you first installs the openssl erratas (including
openssl095a-0.9.5a-9.i386.rpm) and then compile an apache module (for
instance php) with ssl support this breaks mod_ssl.

Since I am compiling php on my own (with different paramenters and stuff)
you may consider this problem for "not supported". That's OK for me. I just
want you to know that this problem exists.

Version-Release number of selected component (if applicable):
openssl095a-0.9.5a-9.i386.rpm
openssl-0.9.6-9.i386.rpm
openssl-devel-0.9.6-9.i386.rpm
php 4.0.6

How Reproducible: Always


Steps to Reproduce:
1. Install all erratas, including openssl095a-0.9.5a-9.i386.rpm and
openssl-*0.9.6-9.i386.rpm
2. recompile php with ssl and imap support
3. Install mod_ssl from RedHat CD
3. restart apache

Actual Results:
Apache dies immediately when trying to start it, no messages in the log
files

Expected Results:
a happy sysadmin :)

Work around:
Remove mod_ssl or recompile the apache source rpm and install it.

Additional Information:
This applies also to RedHat 7.0	
This is my php config:
./configure  --with-apxs=/usr/sbin/apxs --enable-ftp --with-xml --with-dom
--enable-trans-sid --with-config-file-path=/etc/httpd
--with-mysql=shared,/usr --with-pgsql=shared,/usr
--enable-inline-optimization --with-ttf --with-qtdom --with-gd
--enable-gd-native-ttf --with-imap --includedir=/usr --with-openssl=/usr
--with-zlib-dir=/usr --with-ldap=shared,/usr --with-openssl=shared,/usr
Comment 1 Joe Orton 2001-11-23 10:17:02 EST
I presume you are using an old mod_ssl RPM which was linked against the 
old OpenSSL? If so, then yes, that will always fail, since you would be trying to
load two different copies of the OpenSSL libraries at the same time - that's
never going to work.

Note You need to log in before you can comment on or make changes to this bug.