Bug 525003 - db-control report output doesn't include temporary tablespace TEMP_TBS
Summary: db-control report output doesn't include temporary tablespace TEMP_TBS
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other
Version: 530
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-09-22 22:47 UTC by Xixi
Modified: 2010-12-10 20:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-10 20:59:20 UTC


Attachments (Terms of Use)

Description Xixi 2009-09-22 22:47:00 UTC
Description of problem:
On embedded-database Satellites, "db-control report" run as oracle user reports tablespace usage for all relevant tablespaces except TEMP_TBS.  Since in satellite 5.3.0 it can be extended via "db-control extend", db-control report should included it as well.  

Version-Release number of selected component (if applicable):
Satellite 5.3.0 (and earlier)

How reproducible:
Always

Steps to Reproduce:
1. su - oracle
2. db-control report
3.
  
Actual results:
TEMP_TBS not included in output, even though it can be extended with "db-control extend".

Expected results:
TEMP_TBS to be included in output.

Additional info:
rhn-upgrade will include a query to report TEMP_TBS usage, so maybe db-control report can call the same script or use the same query?

Comment 1 Jan Pazdziora 2010-12-10 20:57:01 UTC
As a matter of fact, in Satellite 5.4, db-control shows all the tablespaces:

$ db-control report
Tablespace                  Size    Used   Avail   Use%
DATA_TBS                     23G   19.8G    3.2G    86%
SYSAUX                      500M  384.6M  115.3M    77%
SYSTEM                      400M  273.1M  126.8M    68%
TEMP_TBS                    1.5G      0B    1.5G     0%
UNDO_TBS                    2.9G  419.6M    2.5G    14%
USERS                       256M   1024K    255M     0%
$ rpm -qf `which db-control`
spacewalk-dobby-1.2.7-7.el5sat
$

Comment 2 Jan Pazdziora 2010-12-10 20:58:37 UTC
It went to Spacewalk master as commit 85563a21e26eb2d087c3a847a2712b7e064fc8c5.

Comment 3 Jan Pazdziora 2010-12-10 20:59:20 UTC
Closing, resolved in Satellite 5.4.0.


Note You need to log in before you can comment on or make changes to this bug.