Bug 525125 - new kernels won't boot on Asus NCCH-DL
Summary: new kernels won't boot on Asus NCCH-DL
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 12
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 13:48 UTC by Jeff Guerdat
Modified: 2010-12-04 07:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-04 07:39:49 UTC


Attachments (Terms of Use)
screenshot of where boot hangs (925.20 KB, image/jpeg)
2009-09-24 12:33 UTC, Jeff Guerdat
no flags Details
dmesg using nomodeset (40.02 KB, application/octet-stream)
2009-09-28 12:15 UTC, Jeff Guerdat
no flags Details
messages file comparing failed boot using nomodeset to complete boot using old kernel (164.23 KB, application/octet-stream)
2009-09-28 12:19 UTC, Jeff Guerdat
no flags Details

Description Jeff Guerdat 2009-09-23 13:48:46 UTC
Description of problem: I installed F12-Alpha with no problem and it runs fine with all updates except kernel.  The original kernel, kernel-2.6.31-0.125.4.2.rc5.git2.fc12.i686, works fine.  Any update so far has failed to boot.  The only indication I get/can find is that the various drives on the system (built-in Promise S150 TX4 RAID 0 and 3 USB drives) are found and then it simply stops booting.  CTRL-ALT-DEL works so it's not frozen but I never get past enumerating drives.  I don't know that drive enumeration is the problem, just that it stops there.  I have unplugged the USB drives to eliminate them as a possible cause.


Version-Release number of selected component (if applicable):
Anything > kernel-2.6.31-0.125.4.2.rc5.git2.fc12.i686

How reproducible:
Every time

Steps to Reproduce:
1.Install updated kernel
2.Reboot
3.Hit ESC to watch messages
  
Actual results:
Boot process stalls after enumerating drives

Expected results:
Full boot

Additional info: Tried one time with "rhgb quiet" out of the kernel string and it froze completely, without giving me the expected output.  Might have been a 1 time thing, don't know.

Comment 1 Chuck Ebbert 2009-09-24 03:26:46 UTC
Can you take a picture of the screen when it stalls and attach that?

Comment 2 Jeff Guerdat 2009-09-24 12:33:58 UTC
Created attachment 362483 [details]
screenshot of where boot hangs

This shows the only messages displayed when the boot process hangs.

Comment 3 Jeff Guerdat 2009-09-24 12:45:18 UTC
New detail while mucking about getting the screenshot requested.

I tried the "nomodeset" kernel option to see what happens since I'm using a Radeon HD3650 (actually an Asus card) and there have been issues on at least F11.  That got me past the hang but when gdm was trying to start up, the pointer quickly became very sluggish and no keyboard attempts were responded to.  I tried CTRL-ALT F1-F9 with no luck and the keyboard status indicators didn't change when trying Caps Lock or Num Lock.  The hard drive was showing activity but the only way out was the reset button (I tried CTRL-ALT-DEL).  A reboot into the working kernel showed the messages log filling with entries shown below for the duration of my attempts to get the mouse or keyboard to respond.

Sep 24 07:14:26 localhost kernel: [drm] wait idle failed status : 0xA0003030 0x00000003

My previous comment about removing "rhgb quiet" from the kernel parameters seems to have been a one time thing - no problems today.

Comment 4 Chuck Ebbert 2009-09-25 16:47:50 UTC
It's discovering your raid0 array as three separate drives and isn't assembling the array. This looks like it's a problem with the new dracut initrd.

Comment 5 Jeff Guerdat 2009-09-25 17:06:53 UTC
Ow.  Why would "nomodeset" get past this issue?

Comment 6 Chuck Ebbert 2009-09-27 09:49:32 UTC
(In reply to comment #5)
> Ow.  Why would "nomodeset" get past this issue?  

Maybe the array gets assembled after the graphics hardware inits? Can you attach /var/log/dmesg after booting with nomodeset?

Comment 7 Jeff Guerdat 2009-09-28 12:15:48 UTC
Created attachment 362888 [details]
dmesg using nomodeset

dmesg from failed boot using nomodeset kernel option.  Boot completes to the point where gdm is trying to get to login screen - pointer shows up but activity indicator (circle of "bubbles" around pointer) disappears/stops, pointer becomes very lethargic/sticky and nothing more happens.

Comment 8 Jeff Guerdat 2009-09-28 12:19:07 UTC
Created attachment 362889 [details]
messages file comparing failed boot using nomodeset to complete boot using old kernel

Edited messages file from failed boot using nomodeset kernel option.  Failed boot is first, good boot with old kernel starts at 08:01:39

Comment 9 Jeff Guerdat 2009-09-28 12:20:39 UTC
Added dmesg for a nomodeset boot.  Also attached a messages file to compare same failed boot with a successful boot.

Comment 10 Jeff Guerdat 2009-10-24 18:38:12 UTC
Updated to F12 Beta (install from DVD).  The default install option crapped out at the startup of the GUI.  An install using the basic video option worked as does the installed OS - as long as I use the VESA driver.  I tried to grab the ATI proprietary driver but it won't install with F12 yet.

So, it appears to be a Radeon driver issue, as far as I can tell...

Comment 11 Bug Zapper 2009-11-16 12:48:31 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 12 Bug Zapper 2010-11-04 09:52:07 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Bug Zapper 2010-12-04 07:39:49 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.