Bug 52519 - ppa driver conflicts with usb mouse
ppa driver conflicts with usb mouse
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 12:35 EDT by Leonid Kanter
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 13:42:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2001-08-24 12:35:38 EDT
Description of Problem:

I'm using usb mouse attached to usb-uhci controller. When I attached
parallel port iomega zip100 drive, inserted driver (modrobe ppa), mounted
disk and started to copy files, mouse died. There is fillowing in dmesg:

0x378: FIFO is 16 bytes
0x378: writeIntrThreshold is 16
0x378: readIntrThreshold is 16
0x378: PWord is 8 bits
0x378: Interrupts are ISA-Pulses
0x378: ECP port cfgA=0x10 cfgB=0x48
0x378: ECP settings irq=7 dma=<none or set by other means>
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,COMPAT,EPP,ECP]
parport0: irq 7 detected
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
usb-uhci.c: interrupt, status 3, frame# 804
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 3
ppa: Version 2.07 (for Linux 2.4.x)
ppa: Found device at ID 6, Attempting to use EPP 32 bit
ppa: Communication established with ID 6 using EPP 32 bit
scsi1 : Iomega VPI0 (ppa) interface
  Vendor: IOMEGA    Model: ZIP 100           Rev: J.03
  Type:   Direct-Access                      ANSI SCSI revision: 02
hub.c: USB new device connect on bus1/2, assigned device number 4
input0: USB HID v1.00 Mouse [4D Mouse USB Mouse] on usb1:4.0
Attached scsi removable disk sda at scsi1, channel 0, id 6, lun 0
SCSI device sda: 196608 512-byte hdwr sectors (101 MB)
sda: Write Protect is off
 sda: sda4
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 4
hub.c: USB new device connect on bus1/2, assigned device number 5
input0: USB HID v1.00 Mouse [4D Mouse USB Mouse] on usb1:5.0
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 5
hub.c: USB new device connect on bus1/2, assigned device number 6
input0: USB HID v1.00 Mouse [4D Mouse USB Mouse] on usb1:6.0
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 6
hub.c: USB new device connect on bus1/2, assigned device number 7
input0: USB HID v1.00 Mouse [4D Mouse USB Mouse] on usb1:7.0
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 7
hub.c: 1/2, assigned device number 8
input0: USB HID v1.00 Mouse [4D Mouse USB Mouse] on usb1:8.0
hub.c: already running port 2 disabled by hub (EMI?), re-enabling...
usb.c: USB disconnect on device 8
hub.c: Cannot enable port 2 of hub 1, disabling port.
hub.c: Maybe the USB cable is bad?

When I finished working with zip, I removed ppa module, reloaded usb-uhci
and got mouse working again.

Version-Release number of selected component (if applicable):

2.4.7-2.5

How Reproducible:

always


Actual Results:

USB mouse can't work with ppa zip.

Expected Results:

I think ppa drive and usb mouse must work simultaneosly

Additional Information:

[leon@p504 /]$ cat /proc/interrupts
           CPU0
  0:    2451161          XT-PIC  timer
  1:      23455          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  3:    1048869          XT-PIC  serial
  5:      30574          XT-PIC  soundblaster
  8:          1          XT-PIC  rtc
  9:     236688          XT-PIC  eth0, usb-uhci
 11:     163957          XT-PIC  ide2
 14:         23          XT-PIC  ide0
 15:     505787          XT-PIC  ide1
NMI:          0
ERR:          0
Comment 1 Pete Zaitcev 2001-08-24 13:21:51 EDT
The root cause seems the poor shielding between
parallel and USB. In fact, the message is right there

 hub.c: already running port 2 disabled by hub (EMI?), re-enabling...

EMI stands for Electro-Magnetic Interference.

The following is bothersome though:

  "When I finished working with zip, I removed ppa module,
  reloaded usb-uhci and got mouse working again."

The mouse must recover on unplug-replug automatically
and there must be no need to reload usb-uhci. If usb-uhci
does not recover, that might be a bug. With the
hardware SO crappy as the user's, nobody can give a 100%
guarantee, but I am willing to look into it if usb-uhci
does not recover.

How is Windows coping with it? I am curious... Of course,
no useful messages about EMI may be forthcoming, but still.
Perhaps its driver for ZIP knows how to reduce EMI with
clever timing.
Comment 2 Leonid Kanter 2001-08-24 13:42:53 EDT
I tried one more time and mouse died again after copying 20Mb file from zip
(smaller amount of data may not cause mouse death, just non-smooth movement).
Yes, it's possible to revive it by re-plugging mouse cord even without removing
ppa driver and unmounting zip.

As for Windows, I have w2k installed on other partition but there is no iomega
driver installed. If I found driver, I'll try and report.
Comment 3 Pete Zaitcev 2001-09-20 14:29:08 EDT
I think it's pure EMI.

Note You need to log in before you can comment on or make changes to this bug.