Bug 525207 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd "read" access on Bugzilla.conf.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd "read" access on Bugzil...
Keywords:
Status: CLOSED DUPLICATE of bug 522878
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:d78483b38f7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 16:30 UTC by Zack Cerza
Modified: 2009-09-24 15:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 15:44:31 UTC


Attachments (Terms of Use)

Description Zack Cerza 2009-09-23 16:30:39 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/abrtd "read" access on Bugzilla.conf.

Detailed Description:

[abrtd has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                Bugzilla.conf [ file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-0.0.8.5-1.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64 #1 SMP Thu Sep 10
                              00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Wed 23 Sep 2009 12:26:52 PM EDT
Last Seen                     Wed 23 Sep 2009 12:26:52 PM EDT
Local ID                      216a64d0-2f6d-4cc7-bf61-1c3c03a99592
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253723212.439:50): avc:  denied  { read } for  pid=1508 comm="abrtd" name="Bugzilla.conf" dev=dm-4 ino=205 scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1253723212.439:50): avc:  denied  { open } for  pid=1508 comm="abrtd" name="Bugzilla.conf" dev=dm-4 ino=205 scontext=system_u:system_r:abrt_t:s0 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253723212.439:50): arch=c000003e syscall=2 success=yes exit=0 a0=21a41d8 a1=0 a2=1b6 a3=37 items=0 ppid=1 pid=1508 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0 key=(null)


audit2allow suggests:

#============= abrt_t ==============
allow abrt_t user_home_dir_t:file { read open };

Comment 1 Daniel Walsh 2009-09-24 15:44:31 UTC

*** This bug has been marked as a duplicate of bug 522878 ***


Note You need to log in before you can comment on or make changes to this bug.