Bug 52526 - After building a kernel and installing, boot hangs at sleep 1 cmd in rc.sysinit
Summary: After building a kernel and installing, boot hangs at sleep 1 cmd in rc.sysinit
Status: CLOSED DUPLICATE of bug 45248
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-24 18:05 UTC by August Treubig
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 07:44:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My last config file from the K6/450 (12.88 KB, text/plain)
2001-08-24 20:52 UTC, August Treubig
no flags Details

Description August Treubig 2001-08-24 18:05:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
I have tried to build a new kernel following instructions for RH 7.1
  make oldconfig
  make xconfig  (minor changes)
  make dep
  make bzImage
  make modules
  make modules_install
  make install

on two different machines - A Toshiba Techra 8000 laptop and a desktop with
an AMD K6/450 and ASUS P5A-B mother board.  The results are the same. 
After getting into rc.sysinit and displaying the "press I to enter
interactive mode", the startup hangs on the
"sleep 1" command.  If I comment it out, it hangs on the "mount of the proc
file system".
I have been trying various things on and off for a month.  I even upgraded
the Tecra to 
the latest kernel.  The one that you guys provided, works... The one I
compiled hangs the same way.  

Ok, what am I doing wrong.  I have built kernels before on 5.x..

August


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Build the kernel per Red Hat directions
2. Reboot and choose the new kernel.
3.  It will hang at the point is stated..
	

Expected Results:  It should continue booting

Additional info:

Comment 1 Arjan van de Ven 2001-08-24 19:30:26 UTC
Ok something is funny here. Would you mind attaching your .config file to
this bug so I can have a look at it ?


Comment 2 August Treubig 2001-08-24 20:52:08 UTC
Created attachment 29434 [details]
My last config file from the K6/450

Comment 3 Arjan van de Ven 2001-08-25 07:44:00 UTC
first of all, you made a SMP k6 kernel... I don't think that is what you
wanted; nor do I know if it actually works

Comment 4 August Treubig 2001-08-25 21:27:40 UTC
Ok,  I found the problem.  When I turned SMP off, I fell into an undefined
symbol problem, which I had hit before and caused me to turn it on in the first
place.  However, I looked it up on bugzilla and discovered bug 45248 which
described my problem also.  I followed the procedure at the end of it and I can
boot up sucessfully.  

Please change the doc to state that after changing from SMP to UP or visa versa,
to save the config, do a make mrproper, then restore the config and then a make
oldconfig, etc..

Thanks,

Aug


*** This bug has been marked as a duplicate of 45248 ***


Note You need to log in before you can comment on or make changes to this bug.