Bug 525269 - setroubleshoot: SELinux is preventing /usr/bin/python "lock" access on /var/cache/yum/x86_64/11.91/rawhide/fc799a3b8dfd830b83ba3adbfecb94727601fcac865eb0a64a773631c2433314-primary.sqlite.
Summary: setroubleshoot: SELinux is preventing /usr/bin/python "lock" access on /var/c...
Keywords:
Status: CLOSED DUPLICATE of bug 525268
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:6b8c0a25372...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 18:45 UTC by Zack Cerza
Modified: 2009-09-24 17:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 17:06:19 UTC


Attachments (Terms of Use)

Description Zack Cerza 2009-09-23 18:45:58 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/bin/python "lock" access on
/var/cache/yum/x86_64/11.91/rawhide/fc799a3b8dfd830b83ba3adbfecb94727601fcac865eb0a64a773631c2433314-primary.sqlite.

Detailed Description:

[debuginfo-insta has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by debuginfo-insta. It is not expected that this
access is required by debuginfo-insta and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0
Target Context                system_u:object_r:var_t:s0
Target Objects                /var/cache/yum/x86_64/11.91/rawhide/fc799a3b8dfd83
                              0b83ba3adbfecb94727601fcac865eb0a64a773631c2433314
                              -primary.sqlite [ file ]
Source                        debuginfo-insta
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-2.fc12.x86_64 #1 SMP Thu Sep 10
                              00:25:40 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 23 Sep 2009 02:37:47 PM EDT
Last Seen                     Wed 23 Sep 2009 02:37:47 PM EDT
Local ID                      c20ad9de-ba7d-40e2-a171-63ef512d4b8f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253731067.834:78): avc:  denied  { lock } for  pid=14121 comm="debuginfo-insta" path="/var/cache/yum/x86_64/11.91/rawhide/fc799a3b8dfd830b83ba3adbfecb94727601fcac865eb0a64a773631c2433314-primary.sqlite" dev=dm-0 ino=150857 scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253731067.834:78): arch=c000003e syscall=72 success=yes exit=0 a0=9 a1=6 a2=7fff5c06a910 a3=1 items=0 ppid=1508 pid=14121 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="debuginfo-insta" exe="/usr/bin/python" subj=system_u:system_r:abrt_t:s0 key=(null)


audit2allow suggests:

#============= abrt_t ==============
allow abrt_t var_t:file lock;

Comment 1 Daniel Walsh 2009-09-24 17:06:19 UTC

*** This bug has been marked as a duplicate of bug 525268 ***


Note You need to log in before you can comment on or make changes to this bug.