Bug 525311 - poppler yielding fatal error (Unexpected EOF in JBIG2 stream) on certain PDFs
poppler yielding fatal error (Unexpected EOF in JBIG2 stream) on certain PDFs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: poppler (Show other bugs)
5.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Marek Kašík
Desktop QE
: ZStream
: 545129 575136 (view as bug list)
Depends On:
Blocks: 499522 528146 528147 624702
  Show dependency treegraph
 
Reported: 2009-09-23 17:27 EDT by Yves Perrenoud
Modified: 2016-04-26 11:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: poppler-0.5.4-12.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:11:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yves Perrenoud 2009-09-23 17:27:48 EDT
Description of problem:

As of the last few months, this old version of poppler is having fairly frequent issues with handling PDFs generated by the latest version of Adobe Acrobat (Pro Extended 9), causing evince and pdf2ps for instance to "crash". That said, it might not be related to the latest version of Acrobat, but all the files we've had issues with for now were generated by the latest version.

Here's a sample error message:

Error (43477): 11708 extraneous bytes after segment
Error (43477): Unexpected EOF in JBIG2 stream

However, the latest version of poppler available in Fedora 11, has absolutely no problems handling those documents.

Version-Release number of selected component (if applicable):

poppler-0.5.4-4.4.el5_3.9

How reproducible:

With the right PDF, 100% reproducible. I can't provide any of the PDFs we've been having problems with as they all contain significant confidential information.
Comment 1 Marek Kašík 2009-09-25 08:54:19 EDT
Hi Yves,

I understand that you can not provide PDFs with confidential informations but it is not possible to fix this without a PDF which induces the problem.
Could you create a PDF inducing this problem without confidential informations and attach it to this report?

Thank you

Marek
Comment 8 Marek Kašík 2010-04-12 11:58:10 EDT
*** Bug 545129 has been marked as a duplicate of this bug. ***
Comment 11 Marek Kašík 2010-04-15 11:42:43 EDT
*** Bug 575136 has been marked as a duplicate of this bug. ***
Comment 33 errata-xmlrpc 2012-02-21 01:11:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0236.html

Note You need to log in before you can comment on or make changes to this bug.