Bug 52535 - apache seg faults on startup
Summary: apache seg faults on startup
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: apache   
(Show other bugs)
Version: roswell
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-24 19:20 UTC by Tom Cross
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 14:29:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Cross 2001-08-24 19:20:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-12 i686; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
running /etc/rc.d/init.d/httpd start results in FAILED.

further checking into it, the httpd script tries to start apache like this:

[root@xterm178 httpd]# /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY
-DHAVE_AUTH_ANON -DHAVE_ACTIONS -DHAVE_ALIAS -DHAVE_ASIS -DHAVE_AUTH
-DHAVE_AUTOINDEX -DHAVE_AUTH_DB -DHAVE_AUTH_DBM -DHAVE_CERN_META -DHAVE_CGI
-DHAVE_DIGEST -DHAVE_DIR -DHAVE_ENV -DHAVE_EXAMPLE -DHAVE_EXPIRES
-DHAVE_HEADERS -DHAVE_IMAP -DHAVE_INCLUDE -DHAVE_INFO -DHAVE_LOG_AGENT
-DHAVE_LOG_CONFIG -DHAVE_LOG_REFERER -DHAVE_MIME -DHAVE_MIME_MAGIC
-DHAVE_MMAP_STATIC -DHAVE_NEGOTIATION -DHAVE_REWRITE -DHAVE_SETENVIF
-DHAVE_SPELING -DHAVE_STATUS -DHAVE_UNIQUE_ID -DHAVE_USERDIR
-DHAVE_USERTRACK -DHAVE_VHOST_ALIAS -DHAVE_DAV -DHAVE_PERL -DHAVE_SSL
-DHAVE_PHP4            

Which results in:
Segmentation fault


Version-Release number of selected component (if applicable):

apache-1.3.20-14


How reproducible:
Always

Steps to Reproduce:
1./etc/rc.d/init.d/httpd start
2.
3.
	

Actual Results:  Service FAILED startup, but after further looking into it,
apache says "Segmentation fault"

Expected Results:  Should have started apache

Additional info:

Comment 1 Tom Cross 2001-08-24 19:24:53 UTC
More information: 

Just a default "Server" install of Roswell beta2 on a Dell Dimmension desktop.

I made a few changes to /etc/httpd/conf/httpd.conf, but if I start the apache
deamon manually like this:

/usr/sbin/apache -DHAVE_PERL 

it starts just fine.  If I start it with all of the "-D"'s that the init.d/httpd
script wants to start it with, it seg faults.

Comment 2 Tom Cross 2001-08-24 19:32:15 UTC
I replaced the modified httpd.conf with the one that came with the rpm, same
results.  Seg fault.

Comment 3 Nalin Dahyabhai 2001-08-28 00:01:46 UTC
Which version of the OpenSSL package do you have installed?  Do you have PHP
installed?  If so, this should be fixed in openssl-0.9.6b-7 and later.

Comment 4 Tom Cross 2001-08-28 13:16:22 UTC
Default server install of roswell2, so my versions are:

openssl-devel-0.9.6b-4
openssl-0.9.6b-4
php-4.0.6-5


Comment 5 Nalin Dahyabhai 2001-08-28 14:16:54 UTC
If you (temporarily) remove PHP, does the server start correctly?  If so, then
this is definitely the same problem we're seeing.

Comment 6 Tom Cross 2001-08-28 14:29:17 UTC
BINGO

# rpm -e php php-ldap php-imap
warning: /etc/php.ini saved as /etc/php.ini.rpmsave
[# /etc/rc.d/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd:                                            [  OK  ]

Looks like that did the trick!

Comment 7 Nalin Dahyabhai 2001-08-29 15:56:14 UTC
Okay, this is almost certainly the same problem I've been hitting with
openssl-0.9.6b-4.  If Raw Hide's 0.9.6b-6 doesn't fix it, the -7 in the next
release should (i.e., httpd should start successfully, regardless of whether or
not PHP is installed).  Please reopen this bug ID if you find that -7 doesn't
fix this problem.


Note You need to log in before you can comment on or make changes to this bug.