Bug 52536 - gphoto's html export functionality is b0rken
Summary: gphoto's html export functionality is b0rken
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gphoto   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-24 19:30 UTC by Chuck Mead
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-11 10:46:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chuck Mead 2001-08-24 19:30:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2 i686)

Description of problem:
One of my favorite applications is gphoto. I use it to create web archives
of my digital photos. So today (just back from Mexico City, MX) I am trying
to create an archive of the photos I took at Teotihuacan and I discover
that gphoto no longer works... it's ability to create html on the fly
appears to be completely broken and I am wondering if anyone knows what the
fix is? I get html code which consists of nothing more than empty tags
defining a table.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select a photo directory.
2. Select all photos.
3. Select export.
4. Choose an output directory and a style.
5. Export.
6. No worky, worky... just blank files.

Actual Results:  This is the code which appears in the index file for the
export:

<table border=0><tr>
<td>
</td>
<td>
</td>
<td>
</td>
<td>
</td>
<td>
</td>
</tr><tr>
<td>
</td>
<td>
</td>
<td>
</td>
<td>
</td>
<td>
</td>
</tr><tr>
<td>
</td>
<td>
</td>
<td>
</td>
<td>
</td>
</tr></table>

Expected Results:  The index file should provide a master html index to all
of the pictures using thumbnails.

Additional info:

I tried to back up to the gphoto version included with 7.1 (installed on
roswell1 and roswell2 on two different machines) and that did not work
either.

Comment 1 Tim Waugh 2001-08-24 20:26:21 UTC
I just tried this, and it works with gphoto-0.4.3-13.  I get output like:

[...]
<table>
<tr><td><a href="picture-001.html"><img alt="001" src="thumbnail-001.jpg" 
border="1"></a></td></tr>
<tr><td>Thumbnail 001</td></tr>
<tr><td>thumbnail-001.jpg</td></tr>
</table>
[...]

This is with the 'Default' style.

Are there any particular settings that you are seeing this with?  Is there 
anything interesting in your ~/.xsession-errors file?


Comment 2 Tim Waugh 2001-09-27 11:11:41 UTC
No feedback; closing.


Comment 3 Chuck Mead 2001-09-27 16:03:13 UTC
this should be closed I guess... the problem was a simple case of operator head space gap and timing!



Note You need to log in before you can comment on or make changes to this bug.