Bug 525376 - ibus.desktop should not be installed
ibus.desktop should not be installed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: i18n, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-24 01:54 EDT by A S Alam
Modified: 2013-07-02 20:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-01 00:38:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching .imsettings.log File (7.10 KB, text/plain)
2009-09-24 01:55 EDT, A S Alam
no flags Details
Imsetting file (1.51 KB, application/octet-stream)
2009-09-25 04:01 EDT, A S Alam
no flags Details
Error Screenshot for iBus (352.88 KB, image/jpeg)
2009-10-08 03:07 EDT, A S Alam
no flags Details
parent process graph for ibus (1.75 KB, text/plain)
2009-10-29 00:28 EDT, A S Alam
no flags Details

  None (edit)
Description A S Alam 2009-09-24 01:54:30 EDT
Description of problem:
after Each login, there is error (or just) message that "Unable to keep Input Method Running" (and more detail). But IBus was working Normal after this message. 

Version-Release number of selected component (if applicable):
im-chooser-1.2.7-1.fc12

How reproducible:
Everytime

Steps to Reproduce:
1. login to local language desktop
2. you will get message if not please follow
3. System->Preferences -> Input Method
4. There was nothing Selected
5. Try to Enable Input Method
  
Actual results:
message will be there on Right Top Corner

Expected results:
Default Should be enabled as Ibus was working or no such message

Additional info:
Comment 1 A S Alam 2009-09-24 01:55:42 EDT
Created attachment 362432 [details]
Attaching .imsettings.log File
Comment 2 Akira TAGOH 2009-09-24 03:39:01 EDT
which version of imsettings are you using?
Comment 3 A S Alam 2009-09-24 04:36:50 EDT
imsettings-0.107.3-5.fc12.x86_64
Comment 4 Akira TAGOH 2009-09-24 05:47:42 EDT
Can you have the real steps to reproduce this issue? as the log file you've attached at Comment #1 said, this message appears because ibus-daemon is already running. in other words, the key point is how you can see ibus-daemon running after even logged out.

FWIW there were a bug that imsettings couldn't terminate it properly in the older version. so if you've tried on rawhide box live-updated from the older imsettings, this issue may occurs. and there are no way of preventing it unfortunately.

Otherwise please give me more info how to reproduce that.
Comment 5 A S Alam 2009-09-24 06:10:51 EDT
ok, it was upgrade, also produced when upgrade from Fedora 10 to Fedora 11.
Steps are same, as I login each time, it shows same message, but only with
upgrade (fedora 10 to fedora 11 or fedora 11 ->rawhide).

Please close bug as you find more relevant type (to close)
Comment 6 Akira TAGOH 2009-09-24 06:24:26 EDT
Okay. please make sure you don't see this issue after killing ibus-daemon manually or just reboot your machine. if you still see, please reopen this.

Thanks!
Comment 7 A S Alam 2009-09-24 23:23:56 EDT
Sorry, but it is appearing with each login (even after restart also)
Comment 8 Akira TAGOH 2009-09-25 01:06:33 EDT
Sure. please check if:

1. you're sure no ibus-daemon is running at first.
2. ibus-daemon is running once you log into the desktop and log out. you can see that from the console say. press alt+ctrl+Fn on gdm to switch VT.

then attach .imsettings.log again _before_ logging into the desktop again. also describe what you did during the desktop session is alive.
Comment 9 A S Alam 2009-09-25 04:01:00 EDT
Created attachment 362635 [details]
Imsetting file

after reboot machine, I login once, did Nothing (message was there), 
just logout. copy .imsettings.log file from VT without GUI login.

Let me know if any step was wrong to redo.
Comment 10 Akira TAGOH 2009-09-25 08:39:19 EDT
Did you see that message with even the first login after rebooting? hmm, then please check if ibus-daemon is running after rebooting. if it's there, who's the parent of its process?
Comment 11 Akira TAGOH 2009-10-06 02:25:44 EDT
(In reply to comment #9)
> after reboot machine, I login once, did Nothing (message was there), 
> just logout. copy .imsettings.log file from VT without GUI login.

To clarify more, what kind of the message did you see?
Comment 12 A S Alam 2009-10-08 03:07:03 EDT
Created attachment 364061 [details]
Error Screenshot for iBus

"Unable to keep Input Method Running..."
Screenshot is not very clear, but message is like that
Comment 13 Akira TAGOH 2009-10-08 03:38:06 EDT
Aha. didn't you reboot your machine before this testing? then please read comment #10. I'm not quite sure where that process was being brought up from.

Any further information are welcome too. at least it works for me on GNOME desktop with the users newly created.
Comment 14 sangu 2009-10-25 07:14:22 EDT
The same problem happens in my linux.

locale : ko_KR.UTF-8
$ cat .xinputrc 
XIM=ibus
XIM_PROGRAM="/usr/bin/ibus-daemon"
ICON="/usr/share/icons/hicolor/scalable/apps/ibus.svg"
XIM_ARGS="--xim"
PREFERENCE_PROGRAM=/usr/bin/ibus-setup
SHORT_DESC="IBus"
GTK_IM_MODULE=ibus

if test -f /usr/lib/qt4/plugins/inputmethods/libqtim-ibus.so || \
   test -f /usr/lib64/qt4/plugins/inputmethods/libqtim-ibus.so;
then
    QT_IM_MODULE=ibus
fi

imsettings-0.107.4-2.fc12.x86_64
ibus-1.2.0.20091014-2.fc12.x86_64
ibus-hangul-1.2.0.20090617-2.fc12.x86_64
Comment 15 Akira TAGOH 2009-10-26 04:54:30 EDT
Can anyone give me the useful information as I told at comment #10?
Comment 16 A S Alam 2009-10-29 00:28:36 EDT
Created attachment 366544 [details]
parent process graph for ibus
Comment 17 Akira TAGOH 2009-10-29 00:58:00 EDT
Thanks. I guess you've enabled a kind of the self-running feature with XDG's autostart before. you may have ibus.desktop or something like that in $HOME/.config/autostart ?
Comment 18 Akira TAGOH 2009-10-29 01:10:53 EDT
After the talk with Alam on IRC, my guess is correct. since we don't use this feature in Fedora at least, it may be a good idea to get rid of that file automatically if available. reassigning to ibus for that.
Comment 19 Bug Zapper 2009-11-16 07:50:27 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Peng Huang 2009-11-25 00:44:53 EST
I have removed auto start feature in current ibus. Probably this file was created by early version. Please remove it by self. Thanks.
Comment 21 Akira TAGOH 2009-11-25 01:02:04 EST
Right. but it's not that reasonable to remove by the hand since this causes not working ibus. I don't know how many people used that feature though, the fix in ibus should be easier than the cost of the problem.

Plus, any version of ibus doesn't provide any solutions for *this* issue since the bug reporter complains ibus.desktop introduced the issue ibus not running. so closing as CURRENTRELEASE is wrong at least.
Comment 22 Peng Huang 2009-11-30 22:58:18 EST
Hi Tagoh-san,

Actually, this feature has been removed for a long time (Only 0.1.x has this feature). 1.1.x and 1.2.x do not have it. I think it is not necessary to remove it automatically. If really need it, I suggest do it in xinit script (For exmaple /etc/X11/xinit/xinitrc.d/50-xinput.sh). ibus can not remove it before X init scripts.

If you agree, I will move this bug to imsettings, and we fix it in /etc/X11/xinit/xinitrc.d/50-xinput.sh, or I will close it as wontfix.
Comment 23 Akira TAGOH 2009-12-01 00:27:00 EST
(In reply to comment #22)
> Hi Tagoh-san,
> 
> Actually, this feature has been removed for a long time (Only 0.1.x has this
> feature). 1.1.x and 1.2.x do not have it. I think it is not necessary to remove
> it automatically. If really need it, I suggest do it in xinit script (For
> exmaple /etc/X11/xinit/xinitrc.d/50-xinput.sh). ibus can not remove it before X
> init scripts.

ibus isn't brought up before xinit script right. there are no reasons ibus can't remove it.

The problem is, two ibus instance is going to run. and ibus.desktop is prior to imsettings'. so you can do change the logic in ibus like if there are ibus.desktop under $HOME/.config/autostart, remove it and just exit. this would resolves this issue and imsettings successfully can brings up ibus then.
Comment 24 Peng Huang 2009-12-01 00:38:55 EST
I still think it is not good to do it in ibus.
Users also have right to use gnome-sesstion-properties to create it by self. So I will close it as wontfix. Thanks.

Note You need to log in before you can comment on or make changes to this bug.