This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 52538 - rpm fails to run after upgrading: Program version 3.3.11 doesn't match environment version 3.3.4
rpm fails to run after upgrading: Program version 3.3.11 doesn't match enviro...
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 15:48 EDT by rosa
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 15:48:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rosa 2001-08-24 15:48:52 EDT
Description of Problem:

After upgrading to any rpm version newer than rpm-4.0.3-0.88 on both 
redhat 7.1 and roswell leaves rpm unusable.

Version-Release number of selected component (if applicable):
rpm-4.0.3-0.83, rpm-4.0.3-0.88, rpm-4.0.3-0.91 and rpm-4.0.3-0.93

How Reproducible:

Install roswell and then just install some normal rpm's
(normal in the sense: totally unrelated to rpm, db, glibc etc.)
I'm not 100% sure about this but maybe it was caused by installing 
a package that was built on the system itself ??
Like so
rpm --rebuild gShield-2.7-1.src.rpm
rpm -Uvh gShield-2.7-1.i386.rpm

Another system had redhat 7.1 and has the same error
after installing
rpm-4.0.3-0.83.i386.rpm, ... popt-4.0.3-0.83.i386.rpm
or any newer version up untill rpm-4.0.3-0.93

This is the third time over I have to recover the database
(I don't make backups every hour on non production systems) 
so I'll try my best not to reproduce it anymore :)
 
Actual Results:

All rpm commands fail with:
rpmdb: Program version 3.3.11 doesn't match environment version 3.3.4
error: db3 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)

Expected Results:

rpm works

Additional Information:
	
This was already reported *in a comment* on 52470 but that was closed
with status WONTFIX.
Why ??
Comment 1 Jeff Johnson 2001-08-24 18:16:20 EDT
You need to do
	rm /var/lib/rpm/__db*
And, bug  #52470 was closed WONTFIX because the
database was too badly damaged --for unknown reasons --
to save.

Note You need to log in before you can comment on or make changes to this bug.