Bug 525386 - Can't read /sys/hypervisor/uuid which leads to high load average.
Summary: Can't read /sys/hypervisor/uuid which leads to high load average.
Keywords:
Status: CLOSED DUPLICATE of bug 522827
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 5.4
Assignee: Xen Maintainance List
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 07:35 UTC by wangshibo
Modified: 2010-11-09 12:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-05 20:05:40 UTC


Attachments (Terms of Use)

Description wangshibo 2009-09-24 07:35:13 UTC
Description of problem:
When the daemon of xend stops ,the cron task who is /etc/cron.hourly/mcelog.cron can't read /sys/hypervisor/uuid.It leads to D status of "cat /sys/hypervisor/uuid " which results in high load average 

Version-Release number of selected component (if applicable):
In RHEL5.4 for 64 bits x86_64 xen kernel.

How reproducible:
In xen kernel,make the daemon of xend stop.

Steps to Reproduce:
1.#service xend stop
2.#top  (see the load average by hours) 
3.#ps aux |grep "^D" (there are lots of "D" status process)
     
Actual results:
See the result of 'ps' ,we will find there are a lot of "D" state process.Theses process are waiting for cat /sys/hypervisor/uuid.And the load average become more and more high.
Expected results:
When the daemon of xend stops, the process can read /sys/hypervisor/uuid.The load average is not high by hours. 

Additional info:
In RHEL 5.4 before,we find the bug for Reading /sys/hypervisor/uuid in Dom0 hangs if XenStoreD isn't running.The bugzilla website is https://bugzilla.redhat.com/show_bug.cgi?id=225203

Comment 1 Jiri Denemark 2009-09-24 07:56:37 UTC
Interesting. I can still read /sys/hypervisor/uuid after stopping xend. Are you sure it's not exactly the same issue as in bug 225203? That is, is xenstored running when you try to read uuid?

Comment 4 Jiri Denemark 2009-09-25 07:14:54 UTC
Changing component to kernel-xen to decide if we want to fix this bug this time. Kernel tries to read xenstore and blocks forever if xenstored is not running. There is even a patch in bug 225203. We could also reopen that bug and mark this one as a dup of it. I'll let kernel-xen developers decide...

Comment 5 Scott Dodson 2009-11-05 04:52:03 UTC
Is this not the same as BZ 522827 ?

Comment 6 Peter Tiggerdine 2009-11-05 05:35:53 UTC
Yes I would agree. Duplicate?

Comment 7 Scott Dodson 2009-11-05 20:05:40 UTC

*** This bug has been marked as a duplicate of bug 522827 ***

Comment 10 Chris Lalancette 2010-07-19 13:56:08 UTC
Clearing out old flags for reporting purposes.

Chris Lalancette


Note You need to log in before you can comment on or make changes to this bug.