Bug 525423 - RFE: Octave 3.2.x
Summary: RFE: Octave 3.2.x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL: http://www.gnu.org/software/octave/
Whiteboard:
Depends On: 529522
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 11:02 UTC by Nicola Soranzo
Modified: 2009-11-04 18:21 UTC (History)
7 users (show)

Fixed In Version: 3.2.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-04 12:25:44 UTC


Attachments (Terms of Use)

Description Nicola Soranzo 2009-09-24 11:02:28 UTC
Description of problem:
The new major version 3.2.0 of Octave was released on the 6th June 2009, and a bugfix release 3.2.2 in July. The new release includes a lot of new features, in particular I need the Object Oriented Programming support for MATLAB compatibility.

Version-Release number of selected component (if applicable):
octave-3.0.5-1.fc11

Comment 1 Susi Lehtola 2009-09-24 11:22:32 UTC
It's been in rawhide for two months. If you really want it, pull the SRPM from koji and compile it yourself for F11.

Link to koji builds
http://koji.fedoraproject.org/koji/packageinfo?packageID=2672

Newest SRPM at the moment is
http://kojipkgs.fedoraproject.org/packages/octave/3.2.2/5.fc12/src/octave-3.2.2-5.fc12.src.rpm

Comment 2 Nicola Soranzo 2009-09-24 13:09:27 UTC
(In reply to comment #1)
> It's been in rawhide for two months. If you really want it, pull the SRPM from
> koji and compile it yourself for F11.

I knew that, but I was thinking that a package for Fedora 11 may be useful also for other Octave users since F11 it's going to be supported for ~ other 6 months.

If you don't want to risk regressions and are going to close the bug as "WONTFIX", I'll install this 34 extra packages and rebuild it, no problem :)

Thanks for your interest,
Nicola

Comment 3 Alex Lancaster 2009-10-17 02:45:59 UTC
OK, I'm working on an update for octave F-11.  For reference is a list of packages that need to be rebuilt for the new octave:


# repoquery --whatrequires --all --alldeps octave
plplot-octave-0:5.9.4-1.fc11.i586
GMT-octave-0:4.4.0-2.fc11.i586
mathgl-0:1.9-6.fc11.i586
plplot-octave-0:5.9.2-4.fc11.i586
pfstools-octave-0:1.7.0-5.fc11.i586
qtoctave-0:0.8.1-0.20080825.svn165.fc11.i586
GMT-octave-0:4.5.0-1.fc11.i586
octave-6:3.0.5-1.fc11.i586
octave-devel-6:3.0.5-1.fc11.i586
octave-forge-0:20080831-8.fc11.i586

1. I will start with rebuilding octave (in progress)
2. Then request a buildroot override for octave from rel-eng.
3. Work on rebuilding all the above packages.
4. Push all as a single update to updates-testing via bodhi.
5. Get as much feedback as possible, once enough karma reached, will push to stable.

Comment 4 Alex Lancaster 2009-10-17 05:28:51 UTC
Buildroot override tagging requested: http://fedorahosted.org/rel-eng/ticket/2515

Comment 5 Alex Lancaster 2009-10-18 03:22:59 UTC
Cc'ing Orion (owns plplot, GMT).

Comment 6 Alex Lancaster 2009-10-18 03:24:43 UTC
Also Cc D Hayley, owner of mathgl.

Comment 7 Alex Lancaster 2009-10-18 04:16:06 UTC
Orion:  I successfully made a scratch builds of plplot:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1752572

and GMT:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1752611

against new octave 3.2.3 let me know if OK to commit, rebuild and add to update.

Ulrich: I successfully made a scratch build of pfstools against new octave:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1752585

let me know if OK to commit, rebuild and add to update.

I have also rebuilt my own package, octave-forge successfully:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1752579

Note that all these updates will be pushed to updates-testing to get a good shakedown and will make sure that no broken deps exist before pushing to stable.

Regarding remaining 2 deps:

* qtoctave: only looks for octave at run-time and doesn't require API versioning, so shouldn't need to be added for this update.

* mathgl: doesn't appear to compile against octave 3.2.3, I have opened up a bug against this package (bug #529522) and since this was against the same version as in rawhide/F-12, this means that it is already broken in F-12 in any case, since it seemed to never be rebuilt against the new octave.  So it needs to be fixed in any case.

Comment 8 Ulrich Drepper 2009-10-18 04:39:09 UTC
(In reply to comment #7)
> Ulrich: I successfully made a scratch build of pfstools against new octave:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1752585
> 
> let me know if OK to commit, rebuild and add to update.

Sure, commit it.  Then we'll have no breakage.  I'll in any case hope to update pfstools to the current upstream version before F12.

Comment 9 Orion Poplawski 2009-10-19 14:45:23 UTC
(In reply to comment #7)
> Orion:  I successfully made a scratch builds of plplot:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1752572
> 
> and GMT:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1752611
> 
> against new octave 3.2.3 let me know if OK to commit, rebuild and add to
> update.

Sure, go ahead.  Thanks.

Comment 10 Alex Lancaster 2009-10-19 23:44:17 UTC
(In reply to comment #9)
> (In reply to comment #7)
> > Orion:  I successfully made a scratch builds of plplot:
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=1752572
> > 
> > and GMT:
> > 
> > http://koji.fedoraproject.org/koji/taskinfo?taskID=1752611
> > 
> > against new octave 3.2.3 let me know if OK to commit, rebuild and add to
> > update.
> 
> Sure, go ahead.  Thanks.  

OK, done.  All are now ready except for mathgl, which I may have to omit for the time being (at least for the update in updates-testing) because it depends on a new swig build.

Comment 11 Fedora Update System 2009-10-20 00:07:36 UTC
plplot-5.9.5-1.fc11,pfstools-1.7.0-8.fc11,GMT-4.5.0-4.fc11,octave-forge-20090607-15.fc11,octave-3.2.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/plplot-5.9.5-1.fc11,pfstools-1.7.0-8.fc11,GMT-4.5.0-4.fc11,octave-forge-20090607-15.fc11,octave-3.2.3-1.fc11

Comment 12 Alex Lancaster 2009-10-21 03:14:38 UTC
OK, now successfully rebuilt mathgl (as new SWIG appeared in F-11) and added to update:

http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10548

so the entire update should be ready to go without causing any breakage, so please test as much as possible. (I set the autokarma to 5 to make sure that we get a large number of +1 karma points before pushing).

Comment 13 Alex Lancaster 2009-10-21 03:16:00 UTC
(note the new update with mathgl has yet to go to updates-testing, should be in the next push)

Comment 14 Alex Lancaster 2009-10-27 21:08:41 UTC
By the way, if this works for you, please go to the bodhi update and give the update some more karma points.  That way the update will get pushed more quickly.  Initial testing by at least 3 others seems promising.  

I deliberately set the autokarmism higher (to 5 rather than 3) to be sure it's well tested.   If you have an Fedora Account, your votes will go directly towards that total, if you don't have an account but want to leave feedback, they will still be recorded as positive karma but don't go towards the total, but I will see the points and can push it manually if the general feedback seems good.

Comment 15 Susi Lehtola 2009-10-27 22:04:54 UTC
I hope F-11 doesn't suffer from the same problem as in bug 524493...

Comment 16 Alex Lancaster 2009-10-27 22:23:56 UTC
(In reply to comment #15)
> I hope F-11 doesn't suffer from the same problem as in bug 524493...  

On F-11 I ran the /etc/cron.daily/prelink cron job to force prelinking:

$ grep octave /var/log/prelink/prelink.log 
/usr/lib64/octave-3.2.3/liboctinterp.so                      00000036da800000-00000036db6f2e20
/usr/lib64/octave-3.2.3/libcruft.so                          00000036dbc00000-00000036dbe8b368
/usr/lib64/octave-3.2.3/liboctave.so                         00000036dd800000-00000036de4d3ce8
Prelinking /usr/lib64/octave-3.2.3/libcruft.so.3.2.3
Prelinking /usr/lib64/octave-3.2.3/liboctave.so.3.2.3
Prelinking /usr/lib64/octave-3.2.3/liboctinterp.so.3.2.3
Prelinking /usr/bin/octave-3.2.3


And then re-ran octave, and it all seems fine.

Comment 17 Fedora Update System 2009-11-04 12:25:10 UTC
mathgl-1.9-6.fc11.1, plplot-5.9.5-1.fc11, pfstools-1.7.0-8.fc11, GMT-4.5.0-4.fc11, octave-forge-20090607-15.fc11, octave-3.2.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.