Bug 525538 - Satellite 5.3.0 release notes: please include a blurb that cobbler will overwrite existing /tftpboot setup
Summary: Satellite 5.3.0 release notes: please include a blurb that cobbler will overw...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Release Notes
Version: 530
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Ha
QA Contact: Joshua Wulf
URL:
Whiteboard:
Depends On:
Blocks: sat531-docs2
TreeView+ depends on / blocked
 
Reported: 2009-09-24 18:29 UTC by Xixi
Modified: 2018-10-20 04:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 12:51:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0413 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-05-17 12:50:51 UTC

Description Xixi 2009-09-24 18:29:18 UTC
Description of problem:
Customer upgrading from 5.1.1 to 5.3.0 Satellite saw their entire /tftpboot directory structure changed and PXE no longer working.  They see this as an undocumented change.  

This is most likely due to cobbler setting up PXE, which interfered/overwrite existing setup. Please include a note in the Release Notes.

Version-Release number of selected component (if applicable):
Satellite 5.3.0

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade a pre-5.3.0 satellite with PXE already setup in /tftpboot to 5.3.0 (or installing 5.3.0 on a non-satellite with /tftpboot set up will probably have same effect.) 
2. Try PXE boot and watch it fail, look at altered structure in /tftpboot.
3. Look at Satellite 5.3.0 release notes.
  
Actual results:
The Satellite 5.3.0 release notes mentions cobbler but not that cobbler will overwrite existing /tftpboot/.

Expected results:
Add note to Satellite 5.3.0 release notes that cobbler will overwrite existing /tftpboot/, and if user intends to keep running PXE on their 5.3.0 satellite, change the directory to elsewhere before upgrading/installing.

Additional info:
spoke with jsherrill on IRC

Comment 6 Brandon Perkins 2010-03-06 05:50:00 UTC
NeedInfo.  As best as I can tell there has been no update of the Release Notes since:

rhn-i18n-release-notes-5.3.0.7-1.el4sat

I would say that new docs need to be built, and we need to repackage it into a new rhn-i18n-release-notes package and align it to:

https://errata.devel.redhat.com/errata/show/9351

Agree?

Comment 11 Brandon Perkins 2010-05-14 22:10:34 UTC
Release Pending.  Checked on rlx-3-10.rhndev.redhat.com with:

rhn-i18n-guides-5.3.0.16-1.el5sat
rhn-i18n-release-notes-5.3.0.8-1.el5sat
satellite-branding-5.3.0.28-1.el5sat
satellite-doc-indexes-5.3.24-1.el5sat

Comment 12 errata-xmlrpc 2010-05-17 12:51:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0413.html


Note You need to log in before you can comment on or make changes to this bug.