Bug 52559 - artsc-config in wrong package
artsc-config in wrong package
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 23:32 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-25 00:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-24 23:32:59 EDT
artsc-config is located in the arts package, but the header files 
required to build programs that use arts are located in 
kdelibs-sound-devel.  This makes writing configure scripts more difficult 
because they cannot just test for the existence of artsc-config and 
assume that the headers are also present.

The appropriate fix would be to put artsc-config into the 
kdelibs-sound-devel package.  There is no need for artsc-config unless 
you are building other packages that depend on arts.  Other packages that 
use a *-config program, such as GTK+, also put the -config script into 
the devel package.
Comment 1 Bernhard Rosenkraenzer 2001-08-25 06:10:58 EDT
Fixed in 2.2-6

Note You need to log in before you can comment on or make changes to this bug.