Bug 52559 - artsc-config in wrong package
Summary: artsc-config in wrong package
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-25 03:32 UTC by Need Real Name
Modified: 2007-04-18 16:36 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-08-25 04:15:22 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-08-25 03:32:59 UTC
artsc-config is located in the arts package, but the header files 
required to build programs that use arts are located in 
kdelibs-sound-devel.  This makes writing configure scripts more difficult 
because they cannot just test for the existence of artsc-config and 
assume that the headers are also present.

The appropriate fix would be to put artsc-config into the 
kdelibs-sound-devel package.  There is no need for artsc-config unless 
you are building other packages that depend on arts.  Other packages that 
use a *-config program, such as GTK+, also put the -config script into 
the devel package.

Comment 1 Bernhard Rosenkraenzer 2001-08-25 10:10:58 UTC
Fixed in 2.2-6



Note You need to log in before you can comment on or make changes to this bug.