Bug 525612 - setroubleshoot: SELinux is preventing /usr/libexec/gdm-session-worker "rename" access on .dmrc.O1GL0U.
Summary: setroubleshoot: SELinux is preventing /usr/libexec/gdm-session-worker "r...
Keywords:
Status: CLOSED DUPLICATE of bug 525611
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:5c2bf415b9e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 04:41 UTC by Matěj Cepl
Modified: 2018-04-11 15:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-25 15:00:03 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2009-09-25 04:41:55 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing /usr/libexec/gdm-session-worker "rename" access on
.dmrc.O1GL0U.

Podrobný popis:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. The current boolean settings
do not allow this access. If you have not setup gdm-session-wor to require this
access this may signal an intrusion attempt. If you do intend this access you
need to change the booleans on this system to allow the access.

Povolení přístupu:

Confined processes can be configured to run requiring different access, SELinux
provides booleans to allow you to turn on/off access as needed. The boolean
allow_polyinstantiation is set incorrectly.
Boolean Description:
Enable polyinstantiated directory support.


Příkaz pro opravu:

# setsebool -P allow_polyinstantiation 1

Další informace:

Kontext zdroje                system_u:system_r:xdm_t:s0-s0:c0.c1023
Kontext cíle                 unconfined_u:object_r:user_home_t:s0
Objekty cíle                 .dmrc.O1GL0U [ file ]
Zdroj                         gdm-session-wor
Cesta zdroje                  /usr/libexec/gdm-session-worker
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          gdm-2.27.90-2.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.32-8.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Permissive
Název zásuvného modulu     catchall_boolean
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-33.fc12.x86_64 #1 SMP Thu
                              Sep 17 15:40:43 EDT 2009 x86_64 x86_64
Počet upozornění           1
Poprvé viděno               Pá 25. září 2009, 06:27:27 CEST
Naposledy viděno             Pá 25. září 2009, 06:27:27 CEST
Místní ID                   5d60f93a-a161-47e6-b3c9-1c0c27f7006a
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1253852847.816:315): avc:  denied  { rename } for  pid=14589 comm="gdm-session-wor" name=".dmrc.O1GL0U" dev=dm-9 ino=3242 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253852847.816:315): arch=c000003e syscall=82 success=yes exit=0 a0=d24e50 a1=d28190 a2=d27930 a3=1 items=0 ppid=14558 pid=14589 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=17 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_t ==============
allow xdm_t user_home_t:file rename;

Comment 1 Daniel Walsh 2009-09-25 15:00:03 UTC

*** This bug has been marked as a duplicate of bug 525611 ***


Note You need to log in before you can comment on or make changes to this bug.