Bug 525677 - [RFE] Kickstart bootloader directive driveorder should autofill all drives.
Summary: [RFE] Kickstart bootloader directive driveorder should autofill all drives.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 554476
TreeView+ depends on / blocked
 
Reported: 2009-09-25 09:06 UTC by Wade Mealing
Modified: 2018-10-27 15:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-02 02:33:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wade Mealing 2009-09-25 09:06:29 UTC
Description of problem:

The kickstart files contain:

bootloader --location=mbr --driverorder=cciss/c0d0

This works fine until the system being kickstarted has a non-cciss san device to the system during an install.  

It installs where its supposed to but the entry in the hd entry in the grub gets the wrong numbering and the box won't boot.

Changing it to hd0,0 fixes the problem.  So does this in the kickstart:

bootloader --location=mbr --driverorder=cciss/c0d0,sda,sdb,sdc

The requested feature would be to automatically append/assume the rest of the drive order from what the computer assumes.

Version-Release number of selected component (if applicable):

anaconda-11.1.2.168-1


How reproducible:

Every time, just need to test it on something without cciss, but have the above bootloader in the kickstart.

Steps to Reproduce:
1.  find a server without cciss card.
2.  kickstart a server with the above line in the kickstart file.
3.  Wait.
  
Actual results:

When server reboots, grub has been installed to the wrong location.

Comment 1 Radek Vykydal 2009-10-20 12:03:54 UTC
Wade, I am not able to reproduce the bug with your steps (that is without
cciss card). Could you please reproduce and post following files from installed
(repaired) system ?

/var/log/anaconda.log
/root/anaconda-ks.cfg
/boot/grub/device.map
/boot/grub/grub.conf

Even better would be to reproduce with rhel 5.4 using this updates file that contains some patches to get more logging information:
http://rvykydal.fedorapeople.org/updates.driveorder.img
(you would do it by adding updates=<URL> to anaconda boot parameters).
If necessary, I can prepare updates file for rhel 5.3.

Comment 13 David Cantrell 2010-07-02 02:33:50 UTC
Closing per comment 11.


Note You need to log in before you can comment on or make changes to this bug.