Bug 52571 - Cannot boot 2.4.7-2.9 on a Compaq ProLiant ML530; kudzu ate /etc/modules.conf
Summary: Cannot boot 2.4.7-2.9 on a Compaq ProLiant ML530; kudzu ate /etc/modules.conf
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-25 15:36 UTC by Kjartan Maraas
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-27 20:49:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modules.conf config file (186 bytes, text/plain)
2001-08-25 17:12 UTC, Kjartan Maraas
no flags Details
lspci output (1.27 KB, text/plain)
2001-08-27 08:03 UTC, Arjan van de Ven
no flags Details

Description Kjartan Maraas 2001-08-25 15:36:24 UTC
Description of Problem:

Tried to boot the above kernel on this machine and it failed.

Version-Release number of selected component (if applicable):

2.4.7-2.9, mkinitrd-3.1.6-1 and mkinitrd-3.1.5-1 tried.
removed and installed the kernel after downgrading mkinitrd

How Reproducible:

Every time

Steps to Reproduce:
1. install kernel
2. add it to grub.conf (verified that the file is ok)
3. boot failure

Actual Results:

Fails to boot when mounting root filesystems.

Expected Results:

Booting kernel

Additional Information:

Error message on the console:

Mounting root filesystems
mount: error 19 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2

Comment 1 Kjartan Maraas 2001-08-25 17:12:46 UTC
Created attachment 29514 [details]
modules.conf config file

Comment 2 Arjan van de Ven 2001-08-25 17:23:37 UTC
Confirmed

Same on my testbox; kudzu removed my megaraid from /etc/modules.conf which in
turn confused mkinitrd enough not to include megaraid.o into the initrd...
the kernel then rightfully complains about not finding a root device.

Kudzu ran after I added a NIC to my testmachine, and at that time the module got
removed from /etc/modules.conf.

Adding it by hand again makes this problem go away, at least until kudzu is
reran

Comment 3 Bill Nottingham 2001-08-27 02:13:16 UTC
lspci output?

When did kudzu remove the entry - on reboot?

Comment 4 Arjan van de Ven 2001-08-27 07:44:45 UTC
It removed it when I added a new NIC to my machine, which it detected.

Comment 5 Arjan van de Ven 2001-08-27 08:03:19 UTC
Created attachment 29676 [details]
lspci output

Comment 6 Bill Nottingham 2001-08-27 15:12:51 UTC
what wrote your modules.conf (in both cases)? It's, um, odd.

Comment 7 Bill Nottingham 2001-08-27 15:31:23 UTC
kmarras: is the modules.conf posted for your system correct?

Comment 8 Kjartan Maraas 2001-08-27 15:42:45 UTC
Don't know about correct, but it is the one that I found in /etc :)

Comment 9 Bill Nottingham 2001-08-27 15:49:44 UTC
to be more precise: do you have scsi adapters that aren't listed there?

Comment 10 Kjartan Maraas 2001-08-27 19:06:00 UTC
The cciss module was missing. Probably the same issue as with arjan's. It worked
after rebooting just after the install, but when trying out the new kernel it
wouldn't boot.

This is a Smart 5300 controller if that matters.


Comment 11 Bill Nottingham 2001-10-09 19:15:10 UTC
I'm guessing that this is an artifact of the module order writing problem in the
installer; if this re-occurs with a post-7.2 tree, please re-open!


Note You need to log in before you can comment on or make changes to this bug.