Bug 525735 - Application volume wrongly changes Master volume
Summary: Application volume wrongly changes Master volume
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 11
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 13:39 UTC by ben thompson
Modified: 2009-09-29 03:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-29 03:01:27 UTC


Attachments (Terms of Use)

Description ben thompson 2009-09-25 13:39:11 UTC
Description of problem:
If you change the application volume of rhythmbox using the top-right volume slider the PulseAudio Master volume also changes, I believe the application's volume control should only change the volume of that application (rhythmbox).

Version-Release number of selected component (if applicable):

gstreamer.x86_64 0.10.24-1.fc11
pulseaudio.x86_64 0.9.15-17.fc11
rhythmbox.x86_64 0.12.3-1.fc11

How reproducible:


Steps to Reproduce:
1. Change rhythmbox volume (top-right slider)
2. Observe Master volume changing (non-linear, so watch out as it may suddenly get very loud!)
  
Actual results:
Sliding the volume control in rhythmbox changes the Master volume of pulseaudio in a non-linear way.

Expected results:
Sliding the volume control in rhythmbox should change the application's volume, not master volume.

Additional info:

Happens with both normal and cross-fading engine.
GNU/Linux 2.6.30.5-43.fc11.x86_64

Comment 1 Bastien Nocera 2009-09-25 15:19:41 UTC
PulseAudio changes the sink volume depending on the app's volume. That's called flat-volumes.

Comment 2 ben thompson 2009-09-28 10:27:10 UTC
Hi Bastien, I'm not sure what "sink volume" is, but the volume behaviour I've described can't be something done on purpose, are you saying it is? I'm not sure I understand your comment 100%. I was always different to this in other releases.

Came across the same problem in totem, so this is probably a gstreamer related issue.

Comment 3 Lennart Poettering 2009-09-29 03:01:27 UTC
Yes, we are trying to minimize the number of independent volume sliders in our pipeline, so that users are not confused which volume slider is the one that causes their audio to be too faint.

The way flat volumes implement this is that the device ("sink") volume is always set to the max of the streams connected to it. That way changing the stream volumes always feeds back to the device volume which should minimize confusion and make sure we always use the optimum hardware DAC range for best quality.

So, this is a change in behaviour but actually a feature not a bug, so I am closing this now.


Note You need to log in before you can comment on or make changes to this bug.