Bug 525737 - Eclipse JDT needs new patch
Eclipse JDT needs new patch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-25 09:55 EDT by Rob Lazzurs
Modified: 2009-10-15 18:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.4.2-16.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-15 18:32:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 263877 None None None Never

  None (edit)
Description Rob Lazzurs 2009-09-25 09:55:02 EDT
Description of problem:

We have a problem compiling a class with eclipse and have found the problem to be one which eclipse have already patched.

Version-Release number of selected component (if applicable):

eclipse-jdt-3.4.2-15.fc11.x86_64


How reproducible:

Every time.


Additional info:

Further info on the bug and the patch available in the Eclipse bug which I have added below.

We have confirmed this works as expected in our environment, sorry I could not provide more information but I am not a Java developer.  If there is anything more I can provide please let me know.
Comment 1 Alexander Kurtakov 2009-09-25 10:01:50 EDT
We would need more information because what you reported is not sufficient to determine what the actual problem is. A link to the bug in Eclipse bugzilla will help, if I understood correctly that you have found that it's patched in upstream Eclipse.
Comment 2 Rob Lazzurs 2009-09-25 10:45:19 EDT
The link to the Eclipse Bugzilla was added to the original report and I have checked and this is working, check above the comment boxes.
Comment 3 Alexander Kurtakov 2009-09-25 10:50:37 EDT
(In reply to comment #2)
> The link to the Eclipse Bugzilla was added to the original report and I have
> checked and this is working, check above the comment boxes.  

Oops, I missed that.
Comment 4 Rob Lazzurs 2009-09-25 11:12:21 EDT
If any more information is required to have this patch applied please let me know and I will ask one of our Java developers to comment on this bug.

Thanks again.
Comment 5 Fedora Update System 2009-09-29 01:44:59 EDT
eclipse-3.4.2-16.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/eclipse-3.4.2-16.fc11
Comment 6 Alexander Kurtakov 2009-09-29 01:48:20 EDT
Please test and vote if it works for you so we can get the update to the stable repositories.
Comment 7 Rob Lazzurs 2009-09-29 11:28:41 EDT
Hello,

Tested and this does resolve the issue and left a positive comment on admin.fedoraproject.org, if this is not what you meant by vote then please just let me know.

Thanks again for the very prompt fix :)
Comment 8 Alexander Kurtakov 2009-09-29 12:15:11 EDT
(In reply to comment #7)
> Hello,
> 
> Tested and this does resolve the issue and left a positive comment on
> admin.fedoraproject.org, if this is not what you meant by vote then please just
> let me know.
You should *login*, post your comment with "works for me" selected. This will get the package karma increased. When the karma becomes 3 it will be autopromoted to stable updates or we will have to wait some period. 
> 
> Thanks again for the very prompt fix :)
Comment 9 Fedora Update System 2009-09-29 21:41:22 EDT
eclipse-3.4.2-16.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10112
Comment 10 Fedora Update System 2009-10-15 18:31:56 EDT
eclipse-3.4.2-16.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.