Bug 525741 - Composer crashes when pasting from a java app
Summary: Composer crashes when pasting from a java app
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 14:05 UTC by Brad Smith
Modified: 2018-04-11 17:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-29 23:45:40 UTC


Attachments (Terms of Use)
rpm output (1.33 KB, text/plain)
2009-10-21 00:48 UTC, Brad Smith
no flags Details
thunderbird -g output (1.73 KB, text/plain)
2009-10-21 00:55 UTC, Brad Smith
no flags Details
gdb output with tracing turned on earlier. (2.43 KB, text/plain)
2009-10-21 01:00 UTC, Brad Smith
no flags Details


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 511363 None None None Never

Description Brad Smith 2009-09-25 14:05:57 UTC
Description of problem:
The email composer crashes if you paste text copied from a java app (elluminate, jedit...)

Version-Release number of selected component (if applicable):
[brad@satsuki ~]$ rpm -qa '*thunderbird*'
thunderbird-lightning-1.0-0.6.20090715hg.fc11.x86_64
thunderbird-3.0-2.6.b3.fc11.x86_64
thunderbird-enigmail-0.97a-0.1.cvs20090721.fc11.x86_64
gnome-do-plugins-thunderbird-0.8.1-6.fc11.x86_64

[brad@satsuki ~]$ rpm -qa '*java*'
java-1.6.0-openjdk-plugin-1.6.0.0-29.b16.fc11.x86_64
java-1.6.0-openjdk-1.6.0.0-29.b16.fc11.x86_64
java-1.5.0-gcj-1.5.0.0-28.fc11.x86_64
java_cup-0.10k-2.x86_64
tzdata-java-2009k-2.fc11.noarch


How reproducible:
Always

Steps to Reproduce:
1. Open elluminate, jedit or another java-based app
2. Copy text in the java app
3. Paste text into a new email window
  
Actual results:
Pasted text

Expected results:
Thunderbird goes away

Comment 1 Brad Smith 2009-09-25 16:22:50 UTC
It should also be noted that pasting the text into gnome-terminal and then copying from gnome-terminal into Thunderbird works, so the problem does not seem related to the data being copied, but where it comes from.

Comment 2 Matěj Cepl 2009-09-29 17:04:19 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *thunderbird* *mozilla* *flash* *plugin*

Please also install thunderbird-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install thunderbird

Then run thunderbird with a parameter -g. That will start Thunderbird running inside of gdb debugger. Then use command run and paste the text from your Java app. When it crashes, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 Matěj Cepl 2009-09-29 17:07:29 UTC
Might be a duplicate of the upstream bug, but we need a backtrace to confirm it.

Comment 4 Brad Smith 2009-10-21 00:48:23 UTC
Created attachment 365442 [details]
rpm output

Output of rpm -qa *xulrun* *thunderbird* *mozilla* *flash* *plugin*

Comment 5 Brad Smith 2009-10-21 00:55:51 UTC
Created attachment 365445 [details]
thunderbird -g output

This is the output of thunderbird -g in gdb. It is... underwhealming. I ran thunderbird -g, then 'run', then opened the composer and pasted text from a java app. Thunderbird then crashed, after which I ran "thread apply all backtrace" but got no useful output that I could tell. I'll turn on the backtrace earlier and put the output in another attachment.

Comment 6 Brad Smith 2009-10-21 01:00:03 UTC
Created attachment 365448 [details]
gdb output with tracing turned on earlier.

This is the output of thunderbird -g in gdb, like the previous attachment, but this time I ran "thread apply all backtrace" before running the app. When I did the paste, I got the following in gdb:

"""
Program received signal SIGSEGV, Segmentation fault.
strcmp () at ../sysdeps/x86_64/strcmp.S:29
29	L(oop):	movb	(%rdi), %al
Current language:  auto; currently asm
"""

However, instead of crashing completely, Thunderbird simply froze.

Comment 7 Matěj Cepl 2009-10-29 23:45:40 UTC
We found the copy of this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=511363) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.


Note You need to log in before you can comment on or make changes to this bug.