Bug 525756 - paver-minilib.zip in python-fedora is missing required 'doctools' module
Summary: paver-minilib.zip in python-fedora is missing required 'doctools' module
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-fedora
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Toshio Ernie Kuratomi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 15:16 UTC by BJ Dierkes
Modified: 2009-11-03 21:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-03 21:07:50 UTC


Attachments (Terms of Use)

Description BJ Dierkes 2009-09-25 15:16:46 UTC
Description of problem:

Due to a lack of setup/requirements section in setup.py in the python_fedora source, python-fedora attempts to use 'paver-minilib.zip' locally to resolve the paver dependency, however there appears to be maybe a version incompatibility with this version of 'paver-minilib.zip' as it appears to be missing a required 'doctools' module.  This breaks any projects attempting something like 'python setup.py develop' and resolving deps via the CheezeShop.

Please note that I am talking about the sources here, and not the RPM package.  Everything with the RPM package seems fine... I'm more talking about development environments that would be using something like virtualenv and easy_install.


Version-Release number of selected component (if applicable):

python_fedora-0.3.14


How reproducible:

Every time.


Steps to Reproduce:
1. easy_install python-fedora (when paver is not installed)
2.
3.
  

Actual results:

(env)wdierkes@macbook-pro [server] $ easy_install python-fedora
Searching for python-fedora
Reading http://pypi.python.org/simple/python-fedora/
Reading https://fedorahosted.org/python-fedora
Reading https://fedorahosted.org/releases/p/y/python-fedora/
Best match: python-fedora 0.3.14
Downloading https://fedorahosted.org/releases/p/y/python-fedora/python-fedora-0.3.14.tar.gz
Processing python-fedora-0.3.14.tar.gz
Running python-fedora-0.3.14/setup.py -q bdist_egg --dist-dir /var/folders/8M/8MU+1HkGHR8BHTsD3ftF+++++TI/-Tmp-/easy_install-LC9WEC/python-fedora-0.3.14/egg-dist-tmp-qI2UKj
paver-minilib.zip/paver/path.py:33: DeprecationWarning: the md5 module is deprecated; use hashlib instead
Traceback (most recent call last):
  File "/Users/wdierkes/devel/mirrormanager/env/bin/easy_install", line 8, in <module>
    load_entry_point('setuptools==0.6c9', 'console_scripts', 'easy_install')()
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 1671, in main
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 1659, in with_ei_usage
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 1675, in <lambda>
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 975, in run_commands
    self.run_command(cmd)
  File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 995, in run_command
    cmd_obj.run()
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 211, in run
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 446, in easy_install
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 476, in install_item
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 655, in install_eggs
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 930, in build_and_install
  File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 919, in run_setup
  File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 27, in run_setup
  File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 63, in run
  File "build/bdist.linux-i686/egg/setuptools/sandbox.py", line 29, in <lambda>
  File "setup.py", line 10, in <module>
    raise RuntimeError, \
  File "paver-minilib.zip/paver/tasks.py", line 600, in main
  File "paver-minilib.zip/paver/tasks.py", line 581, in _launch_pavement
  File "pavement.py", line 19, in <module>
ImportError: No module named doctools



Expected results:

The paver libraries would be installed first as a dependency before being used in setup.py, or a fixed paver-minilib.zip would provide doctools.

Comment 1 Toshio Ernie Kuratomi 2009-09-25 16:52:06 UTC
Need to determine if this is fixable in paver, then generate a new python-fedora tarball with the new paver-minilib.

Comment 2 Toshio Ernie Kuratomi 2009-09-27 15:39:48 UTC
Looks like paver supports the idea of build requires already:

http://groups.google.com/group/paver/browse_thread/thread/1a88d395b98b4252

I'll try this in python-fedora.

Comment 3 Toshio Ernie Kuratomi 2009-09-27 16:55:03 UTC
Looks good.  Fixed in upstream bzr repository.

Comment 4 Toshio Ernie Kuratomi 2009-11-03 21:07:50 UTC
0.3.16 should fix this:
http://pypi.python.org/pypi/python-fedora


Note You need to log in before you can comment on or make changes to this bug.