Bug 525765 - EFI for first-generation MacBooks
EFI for first-generation MacBooks
Status: CLOSED DUPLICATE of bug 503149
Product: Fedora
Classification: Fedora
Component: anaconda-images (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-25 12:27 EDT by Fabian Deutsch
Modified: 2009-10-07 11:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 11:35:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2009-09-25 12:27:50 EDT
Description of problem:
first-generation MacBooks (at least mine) use an Intel T5600 CPU, so x86_64 support should be available (alsp cpuinfo is showing the lm flag=64bit). When using the efidisk.img of x86_64, the MacBook won't use/recognize the prepared usb stick.

You will have to use an i686 image, so the MacBook recognizes the usb-stick with an bootia32.efi runnable.


Version-Release number of selected component (if applicable):
rawhide/snap-3

How reproducible:
Always.

Steps to Reproduce:
1. Get a 1-gen MacBook.
2. Prepare usb-stick with x86_64/os/images/efidisk.img and boot
  
Actual results:
macBook will not recognize the problem

Expected results:
MacBook will recognize the usb-stick and start anaconda, including efi support.

Additional info:
Preparing an usb-stick with i686/os/images/efidisk.img works. But will 64bit support be available?
might this be a bug in the MacBook firmware?
Comment 1 Chris Lumens 2009-10-07 11:35:38 EDT

*** This bug has been marked as a duplicate of bug 503149 ***

Note You need to log in before you can comment on or make changes to this bug.