This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 525767 - Black screen on login/ first session. Works on 2nd session.
Black screen on login/ first session. Works on 2nd session.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-25 12:39 EDT by Linuxguy123
Modified: 2010-03-21 11:33 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-21 11:33:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Linuxguy123 2009-09-25 12:39:31 EDT
Description of problem:

I use an external monitor with my laptop, giving me a dual display desktop. (A desktop that spans two displays.)  The laptop display is black when I am logging in.   It is also black if/when I manage to log into a KDE session, although it does flicker a few times with the desktop image before it goes black.  

However, if I log out of that session and log back in, the laptop screen works as it should, as do all subsequent session.  So its just the login and the first session that are black.  After that it works fine.

If I disconnect the external monitor and set the xorg.conf file to use the laptop display only, the laptop display is still black. 

The laptop display is my primary display. The login GUI appears on it and thus I am logging in blind when this happens.

Version-Release number of selected component (if applicable):

]$ yum list \*xorg\* | more                                          
Loaded plugins: dellsysidplugin2, downloadonly, kmdl, priorities, refresh-
              : packagekit
1 packages excluded due to repository priority protections
Installed Packages
xorg-x11-apps.i586                    7.3-8.fc11       installed
xorg-x11-docs.noarch                  1.3-5.fc11       installed
xorg-x11-drivers.i586                 7.3-11.fc11      installed
xorg-x11-drv-acecad.i586              1.3.0-1.fc11     installed
xorg-x11-drv-aiptek.i586              1.2.0-1.fc11     installed
xorg-x11-drv-apm.i586                 1.2.1-2.fc11     installed
xorg-x11-drv-ark.i586                 0.7.1-2.fc11     installed
xorg-x11-drv-ast.i586                 0.87.0-2.fc11    installed
xorg-x11-drv-ati.i586                 6.12.2-14.fc11   installed
xorg-x11-drv-avivo.i586               0.0.1-8.fc11     installed
xorg-x11-drv-chips.i586               1.2.2-1.fc11     @updates
xorg-x11-drv-cirrus.i586              1.2.0-6.fc11     installed
xorg-x11-drv-cyrix.i386               1.1.0-5.fc8      installed
xorg-x11-drv-dummy.i586               0.3.1-2.fc11     installed
xorg-x11-drv-elographics.i586         1.2.3-2.fc11     installed
xorg-x11-drv-evdev.i586               2.2.5-1.fc11     @updates
xorg-x11-drv-fbdev.i586               0.4.0-4.fc11     installed
xorg-x11-drv-fpit.i586                1.3.0-3.fc11     @updates
xorg-x11-drv-geode.i586               2.11.2-1.fc11    installed
xorg-x11-drv-glint.i586               1.2.2-2.fc11     installed
xorg-x11-drv-hyperpen.i586            1.3.0-1.fc11     installed
xorg-x11-drv-i128.i586                1.3.0-2.fc11     installed
xorg-x11-drv-i740.i586                1.2.0-3.fc11     installed
...

$  yum list \*nvidia\* | more                                       
Loaded plugins: dellsysidplugin2, downloadonly, kmdl, priorities, refresh-
              : packagekit
1 packages excluded due to repository priority protections
Installed Packages
kmod-nvidia.i586   185.18.36-1.fc11.1    @rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.6-213.fc11.i586.i586
                    185.18.29-1.fc11      @rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.6-217.2.3.fc11.i586.i586
                   185.18.31-1.fc11      @rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.6-217.2.8.fc11.i586.i586
                    185.18.14-1.fc11.6    @rpmfusion-nonfree-updates
kmod-nvidia-2.6.30.5-43.fc11.i586.i586
                    185.18.36-1.fc11.1    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.i586        185.18.36-1.fc11      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i586   185.18.36-1.fc11      @rpmfusion-nonfree-updates

$ uname -a
Linux localhost.localdomain 2.6.30.5-43.fc11.i586 #1 SMP Thu Aug 27 21:18:54 EDT 2009 i686 i686 i386 GNU/Linux

How reproducible:
Every time.


Steps to Reproduce:
1. Power up the laptop
  
Actual results:

The external monitor will display the Fedora login desktop.  The laptop monitor is black.

If one logs in (blindly), half of the KDE session window will be correctly displayed on the external monitor but the laptop monitor will be black.  


Expected results:

Both the login and 1st KDE session windows should be displayed properly on the laptop display. 

Additional info:

Everything worked fine before the KDE 4.3 update on September 15th.  

cat yum.log | grep "Sep 15"
Sep 15 10:08:16 Updated: oxygen-icon-theme-4.3.1-1.fc11.noarch
Sep 15 10:08:19 Updated: 6:kdelibs-common-4.3.1-3.fc11.i586   
Sep 15 10:08:23 Updated: kdeartwork-wallpapers-4.3.1-1.fc11.noarch
Sep 15 10:10:18 Updated: 1:java-1.6.0-openjdk-javadoc-1.6.0.0-29.b16.fc11.i586
Sep 15 10:10:18 Updated: kdeartwork-sounds-4.3.1-1.fc11.noarch                
Sep 15 10:10:24 Updated: glib2-2.20.5-1.fc11.i586                             
Sep 15 10:10:25 Updated: akonadi-1.2.1-1.fc11.i586                            
Sep 15 10:10:30 Updated: glib2-devel-2.20.5-1.fc11.i586                       
Sep 15 10:10:32 Updated: libgdiplus-2.4.2-3.fc11.i586                         
Sep 15 10:10:41 Updated: mono-core-2.4.2.3-2.fc11.i586                        
Sep 15 10:10:48 Updated: gtk2-2.16.6-2.fc11.i586                              
Sep 15 10:11:24 Updated: 1:java-1.6.0-openjdk-1.6.0.0-29.b16.fc11.i586        
Sep 15 10:11:25 Updated: ksysguardd-4.3.1-1.fc11.i586                         
Sep 15 10:11:29 Updated: tre-0.7.6-1.fc11.i586                                
Sep 15 10:11:37 Updated: 1:mysql-connector-java-5.1.8-1.fc11.i586             
Sep 15 10:11:39 Updated: mono-data-2.4.2.3-2.fc11.i586                        
Sep 15 10:11:39 Updated: mono-data-sqlite-2.4.2.3-2.fc11.i586                 
Sep 15 10:11:40 Updated: libgdiplus-devel-2.4.2-3.fc11.i586                   
Sep 15 10:11:44 Updated: mono-web-2.4.2.3-2.fc11.i586                         
Sep 15 10:11:46 Updated: mono-winforms-2.4.2.3-2.fc11.i586                    
Sep 15 10:12:05 Updated: coreutils-7.2-4.fc11.i586                            
Sep 15 10:12:06 Updated: kde-settings-kdm-4.2-12.1.noarch                     
Sep 15 10:12:08 Updated: mono-extras-2.4.2.3-2.fc11.i586                      
Sep 15 10:12:09 Updated: monodoc-2.4.2.3-2.fc11.i586                          
Sep 15 10:12:14 Updated: util-linux-ng-2.14.2-10.fc11.i586                    
Sep 15 10:12:21 Updated: gtk2-devel-2.16.6-2.fc11.i586                        
Sep 15 10:12:23 Updated: kde-settings-4.2-12.1.noarch                         
Sep 15 10:12:45 Updated: 6:kdelibs-4.3.1-3.fc11.i586                          
Sep 15 10:12:49 Updated: kdepimlibs-4.3.1-1.fc11.i586                         
Sep 15 10:12:50 Updated: kdelibs-experimental-4.3.1-1.fc11.i586               
Sep 15 10:12:51 Updated: kdepimlibs-akonadi-4.3.1-1.fc11.i586                 
Sep 15 10:12:53 Updated: 7:kdegraphics-libs-4.3.1-1.fc11.i586                 
Sep 15 10:12:55 Updated: PyKDE4-4.3.1-3.fc11.i586                             
Sep 15 10:12:59 Updated: kdepim-runtime-4.3.1-1.fc11.i586                     
Sep 15 10:13:00 Updated: kdepim-runtime-libs-4.3.1-1.fc11.i586                
Sep 15 10:13:03 Updated: 7:kdenetwork-libs-4.3.1-1.fc11.i586                  
Sep 15 10:13:04 Updated: 6:kdebase-libs-4.3.1-2.fc11.i586                     
Sep 15 10:13:06 Updated: 6:kdegames-libs-4.3.1-4.fc11.i586                    
Sep 15 10:13:08 Updated: 6:kdemultimedia-libs-4.3.1-1.fc11.i586               
Sep 15 10:13:08 Updated: PyKDE4-akonadi-4.3.1-3.fc11.i586                     
Sep 15 10:13:10 Updated: 7:kio_msits-4.3.1-1.fc11.i586                        
Sep 15 10:13:13 Updated: kde-style-phase-4.3.1-1.fc11.i586                    
Sep 15 10:13:19 Updated: 7:kdegraphics-4.3.1-1.fc11.i586                      
Sep 15 10:13:37 Updated: 6:kdegames-4.3.1-4.fc11.i586                         
Sep 15 10:13:52 Updated: 7:kdenetwork-4.3.1-1.fc11.i586                       
Sep 15 10:13:59 Updated: 7:kdeadmin-4.3.1-1.fc11.i586                         
Sep 15 10:14:06 Updated: PyKDE4-devel-4.3.1-3.fc11.i586
Sep 15 10:14:07 Updated: 6:kdeutils-printer-applet-4.3.1-1.fc11.i586
Sep 15 10:14:22 Updated: kdebase-runtime-4.3.1-1.fc11.i586
Sep 15 10:14:24 Updated: kdeedu-marble-libs-4.3.1-1.fc11.i586
Sep 15 10:14:25 Updated: 6:kdeutils-libs-4.3.1-1.fc11.i586
Sep 15 10:14:30 Updated: 6:kdepim-libs-4.3.1-1.fc11.i586
Sep 15 10:14:32 Updated: kdebase-runtime-libs-4.3.1-1.fc11.i586
Sep 15 10:14:51 Updated: 6:kdepim-4.3.1-1.fc11.i586
Sep 15 10:14:56 Updated: 6:kdeutils-4.3.1-1.fc11.i586
Sep 15 10:15:04 Updated: kdeedu-marble-4.3.1-1.fc11.i586
Sep 15 10:15:06 Updated: kdebase-workspace-libs-4.3.1-1.fc11.i586
Sep 15 10:15:23 Updated: kdebase-workspace-4.3.1-1.fc11.i586
Sep 15 10:15:25 Updated: kdeplasma-addons-libs-4.3.1-1.fc11.i586
Sep 15 10:15:29 Updated: 6:kdemultimedia-4.3.1-1.fc11.i586
Sep 15 10:15:29 Updated: kdeartwork-kxs-4.3.1-1.fc11.i586
Sep 15 10:15:35 Updated: 7:kdetoys-4.3.1-1.fc11.i586
Sep 15 10:15:40 Updated: kdeplasma-addons-4.3.1-1.fc11.i586
Sep 15 10:15:49 Updated: 6:kdebase-4.3.1-2.fc11.i586
Sep 15 10:15:53 Updated: kdeartwork-screensavers-4.3.1-1.fc11.i586
Sep 15 10:15:56 Updated: kdeartwork-4.3.1-1.fc11.i586
Sep 15 10:16:01 Updated: kdm-4.3.1-1.fc11.i586
Sep 15 13:50:39 Installed: color-filesystem-1-5.noarch
Sep 15 13:50:41 Installed: elektra-0.7.0-1.fc11.i586
Sep 15 13:50:43 Installed: oyranos-libs-0.1.9-3.fc11.i586
Sep 15 13:50:43 Installed: ftgl-2.1.2-10.fc11.i586
Sep 15 13:50:46 Installed: cinepaint-libs-0.22.1-12.fc11.2.i586
Sep 15 13:50:47 Installed: libXNVCtrl-169.12-3.fc11.i586
Sep 15 13:50:48 Installed: oyranos-0.1.9-3.fc11.i586
Sep 15 13:50:56 Installed: cinepaint-0.22.1-12.fc11.2.i586

hwbrowser lists my video card as "nVidia Corporation GeForce 8800M GTS"
This hardware has worked just fine (correctly) with Fedora 8,9,10 and 11.  This is the first time I have had a video problem with it. 

I'm not sure which component to attach this to.  I selected Xorg because I thought it was the most likely culprit.  Obviously, I might be wrong.
Comment 1 Linuxguy123 2009-09-25 12:43:26 EDT
Pardon me... my laptop display has been back since the first KDE4.3 update on August 25th, not September 15th.

From yum.log:
Aug 25 07:44:17 Updated: ksysguardd-4.3.0-9.fc11.i586                                                              
Aug 25 07:45:47 Updated: oxygen-icon-theme-4.3.0-1.fc11.noarch                                                     
Aug 25 07:45:49 Updated: 6:kdelibs-common-4.3.0-6.fc11.i586                                                        
Aug 25 07:45:57 Updated: kdeartwork-wallpapers-4.3.0-2.fc11.noarch                                                 
Aug 25 07:45:57 Updated: kdeartwork-sounds-4.3.0-2.fc11.noarch                                                     
Aug 25 07:46:26 Updated: 6:kdelibs-4.3.0-6.fc11.i586                                                               
Aug 25 07:46:31 Updated: kdepimlibs-4.3.0-2.fc11.i586                                                              
Aug 25 07:46:33 Updated: 7:kdegraphics-libs-4.3.0-1.fc11.i586                                                      
Aug 25 07:46:34 Updated: kdepimlibs-akonadi-4.3.0-2.fc11.i586                                                      
Aug 25 07:46:37 Installed: kdelibs-experimental-4.3.0-1.fc11.i586                                                  
Aug 25 07:46:40 Updated: PyKDE4-4.3.0-4.fc11.1.i586                                                                
Aug 25 07:46:42 Updated: 7:kdenetwork-libs-4.3.0-1.fc11.i586                                                       
Aug 25 07:46:44 Updated: 6:kdebase-libs-4.3.0-1.fc11.i586                                                          
Aug 25 07:46:46 Updated: 6:kdemultimedia-libs-4.3.0-1.fc11.i586                                                    
Aug 25 07:46:48 Updated: 6:kdegames-libs-4.3.0-2.fc11.i586                                                         
Aug 25 07:47:02 Updated: PyKDE4-akonadi-4.3.0-4.fc11.1.i586                                                        
Aug 25 07:47:03 Updated: 7:kio_msits-4.3.0-1.fc11.i586                                                             
Aug 25 07:47:03 Installed: kde-style-phase-4.3.0-2.fc11.i586                                                       
Aug 25 07:47:18 Updated: 7:kdegraphics-4.3.0-1.fc11.i586                                                           
Aug 25 07:47:39 Updated: 6:kdegames-4.3.0-2.fc11.i586                                                              
Aug 25 07:47:55 Updated: 7:kdenetwork-4.3.0-1.fc11.i586                                                            
Aug 25 07:47:58 Updated: 7:kdeadmin-4.3.0-1.fc11.i586                                                              
Aug 25 07:48:04 Updated: PyKDE4-devel-4.3.0-4.fc11.1.i586                                                          
Aug 25 07:48:06 Updated: 6:kdeutils-printer-applet-4.3.0-3.fc11.i586                                               
Aug 25 07:48:08 Updated: kdebase-workspace-libs-4.3.0-9.fc11.i586                                                  
Aug 25 07:48:25 Updated: kdebase-runtime-4.3.0-4.fc11.i586                                                         
Aug 25 07:48:42 Installed: kdebase-workspace-4.3.0-9.fc11.i586                                                     
Aug 25 07:48:44 Installed: kdeedu-marble-libs-4.3.0-6.fc11.i586                                                    
Aug 25 07:48:45 Installed: kdepim-runtime-libs-4.3.0-1.fc11.i586                                                   
Aug 25 07:48:47 Updated: kdebase-runtime-libs-4.3.0-4.fc11.i586                                                    
Aug 25 07:48:55 Installed: kdeedu-marble-4.3.0-6.fc11.i586                                                         
Aug 25 07:48:56 Installed: kdeplasma-addons-libs-4.3.0-8.fc11.i586                                                 
Aug 25 07:48:57 Installed: 6:kdeutils-libs-4.3.0-3.fc11.i586                                                       
Aug 25 07:49:00 Installed: kdepim-runtime-4.3.0-1.fc11.i586                                                        
Aug 25 07:49:08 Installed: 6:kdeutils-4.3.0-3.fc11.i586                                                            
Aug 25 07:49:13 Installed: kdeplasma-addons-4.3.0-8.fc11.i586                                                      
Aug 25 07:49:17 Updated: 6:kdemultimedia-4.3.0-1.fc11.i586                                                         
Aug 25 07:49:18 Updated: kdeartwork-kxs-4.3.0-2.fc11.i586                                                          
Aug 25 07:49:27 Updated: 6:kdebase-4.3.0-1.fc11.i586                                                               
Aug 25 07:49:34 Updated: 7:kdetoys-4.3.0-1.fc11.i586                                                               
Aug 25 07:49:37 Updated: kdm-4.3.0-9.fc11.i586                                                                     
Aug 25 07:49:41 Updated: kdeartwork-screensavers-4.3.0-2.fc11.i586                                                 
Aug 25 07:50:04 Updated: gnome-power-manager-2.26.4-3.fc11.i586                                                    
Aug 25 07:50:09 Installed: kdeartwork-4.3.0-2.fc11.i586                                                            
Aug 25 07:50:21 Updated: 6:kdepim-libs-4.3.0-4.fc11.i586                                                           
Aug 25 07:50:38 Updated: 6:kdepim-4.3.0-4.fc11.i586               

I've been waiting patiently for an update to fix this issue, but since they haven't, I though I would report it. 

Looking at the items that were updated in that session, I am now wondering if its a problem within kdm, not xorg.

Thanks
Comment 2 Matěj Cepl 2009-10-12 16:53:28 EDT
Given that most of your upgraded packages are KDE-related (with exception of gnome-power-manager), it doesn't seem like a xorg-x11 bug. Reassigning to KDE maintainers, eagerly awaiting their opinion on the matter.
Comment 3 Kevin Kofler 2009-10-12 16:56:39 EDT
I strongly suspect a bug in the proprietary nvidia driver which just happens to be triggered by the KDE upgrade.
Comment 4 Linuxguy123 2009-10-12 22:25:45 EDT
This is still a problem, even after updating to the latest nvidia xorg drivers.

From yum.log:

Oct 12 20:06:40 Updated: xorg-x11-drv-nvidia-libs-185.18.36-3.fc11.i586
Oct 12 20:06:44 Updated: xorg-x11-drv-nvidia-185.18.36-3.fc11.i586
Comment 5 Steven M. Parrish 2009-10-18 16:09:57 EDT
In order to narrow this down we need you to uninstall the proprietary nvidia driver and switch to nouveau instead.  If the problem disappears then it is an issue with the nvidia driver which we dont support so you'll have to wait for nvidia to fix it.  If the problem persists with the nouveau driver let us know.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Linuxguy123 2009-10-20 19:09:12 EDT
I'll test this when I am less busy later in the week.
Comment 7 Linuxguy123 2009-12-14 18:17:45 EST
This has ceased to be a problem after updating to Fedora 12.

Note You need to log in before you can comment on or make changes to this bug.