Bug 52577 - RFE: limit konsole history size
RFE: limit konsole history size
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-25 15:19 EDT by Robert D. Young
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-28 05:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert D. Young 2001-08-25 15:19:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Some data written into tmp does not get cleaned up and slowly fills
the entire file system: either /tmp or / root if /tmp is part of it.
The unremoved data is evident via "df" report but not visible via
"ls" of "du" (thus appears to be raw disk data). I've only been able
to cleanup the data via a destructive "mkfs". This problem is observed
on all (about 10) of my systems with or without all the latest 7.1
Errata patches installed including 2.4.3 kernel patches. My installations 
include most all Redhat packages. The problem is
visible even immediately following a fresh install after initial
boot. Examples of programs that create the disk leakage are "gnu make"
and the "df" command itself (sometimes df needs to be run several
times for the /tmp or / disk space use to be registered ... less
frequently the larger the fstab) ... not a
corresponding increase with du -s /tmp command is observed. 
Interestingly this behavior (at least with df stimuli does not
occur if rlogin'ed into the machine). It also seems to be
partly dependent on being in the KDE env (df related leak does not
seem to cccur when in a non-gui console window although the
gnu make leak seems to still be present).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.enter kde; note size of /tmp with "du" and "df"
2.run numerous "df" commands (iterations needed to illustrate
  problem vary based on df table size)
3.see df of /tmp space increase while no increase in "du -s /tmp"
  or any new files/dirs visible under /tmp via "ls".
	

Actual Results:  /tmp or / disk space usage increased

Expected Results:  no increase in disk space usage

Additional info:

space not recoverable unless mkfs is done
Comment 1 Need Real Name 2001-08-27 11:21:53 EDT
What you describing is just a bug of konsole which has an 
unlimited history which fills the file system. 

(Just have a look at 
http://bugs.kde.org/db/30/3004.html
)

The difference from df and du is just the size of the history of konsole.

Comment 2 Bernhard Rosenkraenzer 2001-08-28 05:36:51 EDT
True - and the fileutils tools are actually doing the right thing (by not 
counting changes in files that are still opened for writing).

I agree that konsole history size should be limited though.
Comment 3 Bernhard Rosenkraenzer 2002-01-22 06:58:36 EST
This is fixed in KDE 2.2, which was shipped with 7.2.

Note You need to log in before you can comment on or make changes to this bug.