Bug 525803 - [abrt] crash detected in yum-3.2.24-5.fc12
[abrt] crash detected in yum-3.2.24-5.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:d92d8750
:
: 526750 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-25 15:56 EDT by Gene Czarcinski
Modified: 2014-01-21 18:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-28 16:26:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.64 KB, text/plain)
2009-09-25 15:56 EDT, Gene Czarcinski
no flags Details
local.repo config file (1.16 KB, application/octet-stream)
2009-09-26 12:19 EDT, Gene Czarcinski
no flags Details
error messages and traceback (5.87 KB, text/plain)
2009-09-26 12:20 EDT, Gene Czarcinski
no flags Details
list of packages in repo causing problem (32.57 KB, text/plain)
2009-09-26 12:23 EDT, Gene Czarcinski
no flags Details
result of running createrepo --database (4.53 KB, text/plain)
2009-09-28 13:59 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2009-09-25 15:56:36 EDT
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
attempted check-update with --disablerepo=rawhide

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/bin/python /usr/bin/yum check-update 


component
-----
yum


executable
-----
/usr/bin/yum


kernel
-----
2.6.31-33.fc12.x86_64


package
-----
yum-3.2.24-5.fc12


uuid
-----
d92d8750
Comment 1 Gene Czarcinski 2009-09-25 15:56:38 EDT
Created attachment 362715 [details]
File: backtrace
Comment 2 Gene Czarcinski 2009-09-26 12:18:36 EDT
I have been having some serios problems with yum on a couple of systems plus a number of different qemu-kvm guests all running F12/alpha/rawhide-updates.

Because of the number of systems+guests I have running f12/rawhide, I have created a local mirror yum repository.  To populate this local repository, I use --downloadonly to get the package updates off one of the Internet mirrors and then copy them to my local repository.  After each update of new packages, I run createrepo.

This worked fine until recently, then, suddenly it stopped working and I get the attached error messages and traceback.  I am using the attached local.repo file.

I have isolated the problem to being some package in the local repo.  If I disable it, things (like check-update) work ... otherwise it does not.

I stated out accumulating updates and got to around 2100+ when things started dying.  I then put that repo aside and created a new repo (with --downloadonly) which does not contain any duplicates (800+ packages) but this also has the problem and I put it aside also.  I finally created an empty local repo, no problem.  I populated this repo with 9 packages (kernel-* and abrt-*) and everything still works.

Conclusion: some package or combination of packages gives yum problems.

BTW, the repo itself is running on a Fedora 11 server.
Comment 3 Gene Czarcinski 2009-09-26 12:19:26 EDT
Created attachment 362762 [details]
local.repo config file
Comment 4 Gene Czarcinski 2009-09-26 12:20:24 EDT
Created attachment 362763 [details]
error messages and traceback
Comment 5 Gene Czarcinski 2009-09-26 12:23:34 EDT
Created attachment 362764 [details]
list of packages in repo causing problem
Comment 6 Gene Czarcinski 2009-09-26 15:03:26 EDT
OK, I have identified the set of packages that are the problem.  If they are in the local repository, then yum barfs.  If they are not in the local repository (but still in rawhide), then yum is OK.

The packages are cyrus-sasl-* 2.1.23-3 and 2.1.23-4 (either one).

With cyrus-sasl-* 2.1.23-2 in the local repository yum is OK.
Comment 7 James Antill 2009-09-28 11:58:09 EDT
What version of createrepo are you using?

Also this problem will likely disappear if you use --database on the server side.
Comment 8 Gene Czarcinski 2009-09-28 12:18:49 EDT
The server is running on a F11 system with createrepo-0.9.7-7.fc11.noarch

I have learned just enough about running an httpd server to be able to set it up as the repository server.  Could you expand a bit on "--database" or point me to something about it?
Comment 9 James Antill 2009-09-28 13:06:42 EDT
By "server side" I meant as an argument to createrepo. See the documentation on recommended options, here:

http://yum.baseurl.org/wiki/RepoCreate
Comment 10 Gene Czarcinski 2009-09-28 13:59:09 EDT
OK, downloaded the cyrus-sasl-* packages again and put them in my local repo.  Then, over to my f12alpha system and I ran yum and it still has the problem as expected.

Back to the server and tried running createrepo --database ...

OOps ... it seems to have the same problem that yum had.  Console output is attached.
Comment 11 Gene Czarcinski 2009-09-28 13:59:57 EDT
Created attachment 362927 [details]
result of running createrepo --database
Comment 12 seth vidal 2009-09-28 15:44:48 EDT
okay. I see

it is older yum and older createrepo causing this.


if you update to yum from rawhide on the site that is making the metadata it'll
be hunky dory

I suspect 3.2.24 from F11-updates-testing will also make it all work.
Comment 13 Gene Czarcinski 2009-09-28 16:26:29 EDT
For a while, I thought you must be incorrect ... updating yum to 3.2.24-2 on the F11 server would "fix" createrepo on that server ... but it did fix it!

createrepo on the F11 server now runs and (even more important) yum on the F12-rawhide system also runs!

I am not sure what there is about cyrus-sasl-* packages that give yum fits but it must be something.  No other packages have had a problem.

Closing as fixed in yum-3.2.24-2.fc11
Comment 14 seth vidal 2009-10-01 15:53:23 EDT
*** Bug 526750 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.