Bug 52582 - Rebuild of bind-9.1.3-3.src.rpm fails with parse errors
Summary: Rebuild of bind-9.1.3-3.src.rpm fails with parse errors
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bind   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-25 20:47 UTC by Brian Bruns
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-26 02:54:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exact output from rpm --rebuild on the src.rpm (78.36 KB, text/plain)
2001-08-25 20:48 UTC, Brian Bruns
no flags Details

Description Brian Bruns 2001-08-25 20:47:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Win98; U)

Description of problem:
When bind-9.1.3-3.src.rpm is rebuild using rpm --rebuild, it gets to dst_api.c and then bombs out with several pages of parse errors.  See 
attached file for the entire output of compile attempt. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuild bind-9.1.3-3.src.rpm
	

Actual Results:  See attached file...

Expected Results:  Compile should have completed without errors and final packages should have been produced in 
/usr/src/redhat/RPMS/i386

Additional info:

I'm running the latest Rawhide, glibc 2.2.4-5, gcc-2.96-96 on a dual proc i686 Pentium II 333 with 256 MB of RAM

Comment 1 Brian Bruns 2001-08-25 20:48:07 UTC
Created attachment 29594 [details]
Exact output from rpm --rebuild on the src.rpm

Comment 2 Brian Bruns 2001-08-26 02:34:56 UTC
On a side note, I build it by hand without using RPM (you know, the old fashioned way), and it builds fine.

Comment 3 Brian Bruns 2001-08-26 02:54:46 UTC
Ok, now I'm really confused..  but here goes

In the spec file, I removed "--with-openssl=/usr" from the %configure line and it builds correctly from a 'rpm ba --clean bind.spec' in 
/usr/src/redhat/SPECS.

Any ideas?

Comment 4 Bernhard Rosenkraenzer 2001-08-27 10:12:01 UTC
Yes, looks like you're using an openssl version from stone age. ;)
No problems here with openssl 0.9.6b-5.


Comment 5 Brian Bruns 2001-08-27 12:05:01 UTC
Actually, it wasn't.  OpenSSL was 0.9.6b-4.  I rm'd all of my openssl headers, then reinstalled the OpenSSL-0.9.6b-4 RPMs, and it still bombed out.  I was 
forced to rebuild from source by hand and install by hand before I could compile again.   I'll give 0.9.6b-5 a try, but I'm leaning towards something in the 
old -4 and -3 RPMS being at fault...


Note You need to log in before you can comment on or make changes to this bug.